Bug 198809

Summary: Clicking the up/down spin buttons for a number input increments/decrements by 2
Product: WebKit Reporter: Devin Rousso <drousso>
Component: FormsAssignee: Timothy Hatcher <timothy>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, commit-queue, darin, drousso, rniwa, timothy, webkit-bug-importer, wenson_hsieh
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
URL: data:text/html,<html><body><input%20type="number"%20value="0"></body></html>
Attachments:
Description Flags
Patch none

Description Devin Rousso 2019-06-12 15:01:05 PDT
# STEPS TO REPRODUCE:
1. data:text/html,<html><body><input%20type="number" value="0"></body></html>
2. click the up/down spin button
 => value changes to 2/-2

NOTE: this does NOT happen if you use the up/down arrow keys.
Comment 1 Wenson Hsieh 2019-06-12 15:05:21 PDT
<rdar://problem/51431402>
Comment 2 Tim Horton 2019-06-25 16:19:32 PDT
*** Bug 199210 has been marked as a duplicate of this bug. ***
Comment 3 Timothy Hatcher 2019-06-25 16:24:01 PDT
Created attachment 372873 [details]
Patch
Comment 4 WebKit Commit Bot 2019-06-25 16:42:09 PDT
Comment on attachment 372873 [details]
Patch

Clearing flags on attachment: 372873

Committed r246818: <https://trac.webkit.org/changeset/246818>
Comment 5 WebKit Commit Bot 2019-06-25 16:42:11 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Darin Adler 2019-07-03 15:43:20 PDT
Should we still respect the settings to match AppKit scroller behavior? The settings haven’t been removed, it’s just that the defaulting mechanism used has changed.
Comment 7 Darin Adler 2019-07-03 15:43:43 PDT
I suppose spin buttons are not scrollers, so it’s strange to respect the setting here.