Bug 198767

Summary: Integrate scrollbar gestures for iOS
Product: WebKit Reporter: Megan Gardner <megan_gardner>
Component: New BugsAssignee: Megan Gardner <megan_gardner>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, thorton, timothy, webkit-bug-importer, wenson_hsieh
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
wenson_hsieh: review+
Patch none

Description Megan Gardner 2019-06-11 14:12:11 PDT
Integrate scrollbar gestures for iOS
Comment 1 Megan Gardner 2019-06-11 14:13:06 PDT
Created attachment 371878 [details]
Patch
Comment 2 Radar WebKit Bug Importer 2019-06-11 14:28:50 PDT
<rdar://problem/51640249>
Comment 3 Wenson Hsieh 2019-06-11 14:40:40 PDT
Comment on attachment 371878 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=371878&action=review

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:1758
> +static BOOL _WKGestureRecognizerIsBuiltInScrollViewGestureRecognizer(UIGestureRecognizer *recognizer)

Nit - isBuiltInScrollViewGestureRecognizer()?

We typically only put a WK or _WK prefix on API or SPI.
Comment 4 Tim Horton 2019-06-11 14:42:28 PDT
Comment on attachment 371878 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=371878&action=review

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:1758
> +static BOOL _WKGestureRecognizerIsBuiltInScrollViewGestureRecognizer(UIGestureRecognizer *recognizer)

drop the _WK. Probably just "isBuiltInScrollViewGestureRecognizer", even.

> Source/WebKit/UIProcess/ios/WKContentViewInteraction.mm:1771
> +    BOOL conflictsWithBuiltInGesture = _WKGestureRecognizerIsBuiltInScrollViewGestureRecognizer(preventedGestureRecognizer);

I don't think "conflictsWith" is the right phrasing?
Comment 5 Megan Gardner 2019-06-11 15:01:33 PDT
Created attachment 371883 [details]
Patch
Comment 6 WebKit Commit Bot 2019-06-11 17:24:15 PDT
Comment on attachment 371883 [details]
Patch

Clearing flags on attachment: 371883

Committed r246342: <https://trac.webkit.org/changeset/246342>