Bug 197771

Summary: [Flatpak] Use the safe PyYAML loader if available
Product: WebKit Reporter: Adrian Perez <aperez>
Component: Tools / TestsAssignee: Adrian Perez <aperez>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, calvaris, cgarcia, commit-queue, lforschler, pnormand, tsaunier, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Adrian Perez 2019-05-10 06:39:32 PDT
Current versions of PyYAML give the following warning:

  /home/aperez/devel/WebKit/Tools/flatpak/flatpakutils.py:159: YAMLLoadWarning: calling yaml.load() without Loader=... is deprecated, as the default Loader is unsafe. Please read https://msg.pyyaml.org/load for full details.                                                    
    manifest = yaml.load(contents)                                    

Let's fix this and use “yaml.safe_load()” whenever it's available.
Comment 1 Adrian Perez 2019-05-10 06:42:21 PDT
Created attachment 369551 [details]
Patch
Comment 2 WebKit Commit Bot 2019-05-10 07:42:33 PDT
Comment on attachment 369551 [details]
Patch

Clearing flags on attachment: 369551

Committed r245172: <https://trac.webkit.org/changeset/245172>
Comment 3 WebKit Commit Bot 2019-05-10 07:42:34 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2019-05-10 07:43:21 PDT
<rdar://problem/50662814>