Bug 197573

Summary: [iOS] outlook.live.com: Compose email frame not fully visible and not scrollable
Product: WebKit Reporter: zalan <zalan>
Component: Layout and RenderingAssignee: zalan <zalan>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, commit-queue, simon.fraser, webkit-bug-importer, wenson_hsieh, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description zalan 2019-05-03 13:26:35 PDT
<rdar://problem/48008441>
Comment 1 Radar WebKit Bug Importer 2019-05-03 13:27:12 PDT
<rdar://problem/50454671>
Comment 2 zalan 2019-05-03 13:28:35 PDT
(In reply to Radar WebKit Bug Importer from comment #1)
> <rdar://problem/50454671>
well thank you very much.
Comment 3 zalan 2019-05-03 15:15:54 PDT
Created attachment 369000 [details]
Patch
Comment 4 Brent Fulgham 2019-05-03 15:37:41 PDT
Comment on attachment 369000 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369000&action=review

> Source/WebCore/page/Quirks.cpp:73
> +#if PLATFORM(IOS_FAMILY)

I don't think we need to restrict this to iOS -- you can totally hit this by putting the web view Into the right size.
Comment 5 zalan 2019-05-03 15:49:45 PDT
(In reply to Brent Fulgham from comment #4)
> Comment on attachment 369000 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=369000&action=review
> 
> > Source/WebCore/page/Quirks.cpp:73
> > +#if PLATFORM(IOS_FAMILY)
> 
> I don't think we need to restrict this to iOS -- you can totally hit this by
> putting the web view Into the right size.
yeah, though the viewportconfig concept is iOS only atm.
Comment 6 zalan 2019-05-03 16:27:16 PDT
Created attachment 369017 [details]
Patch
Comment 7 Wenson Hsieh 2019-05-03 16:53:28 PDT
Comment on attachment 369017 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=369017&action=review

> Source/WebKit/WebProcess/WebPage/ios/WebPageIOS.mm:2885
> +    viewportChanged |= m_viewportConfiguration.setViewLayoutSize(adjustedViewLayoutSize(viewLayoutSize));

Nit - I have a slight preference for a more explicit name that makes it clear that this is only here to support hard-coded site-specific layout width quirks, and shouldn't be used for more general purposes. How about something like viewLayoutSizeAdjustedForQuirks?
Comment 8 zalan 2019-05-03 18:46:33 PDT
Created attachment 369034 [details]
Patch
Comment 9 WebKit Commit Bot 2019-05-03 19:25:08 PDT
Comment on attachment 369034 [details]
Patch

Clearing flags on attachment: 369034

Committed r244944: <https://trac.webkit.org/changeset/244944>
Comment 10 WebKit Commit Bot 2019-05-03 19:25:10 PDT
All reviewed patches have been landed.  Closing bug.