Bug 19676

Summary: [Gtk] text-shadow should apply to text decorations as well
Product: WebKit Reporter: Jonathon Jongsma (jonner) <jonathon>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: mrobinson
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
patch to implement drawing shadows for lines
none
Updated patch due to changes from bug #19727 eric: review-

Description Jonathon Jongsma (jonner) 2008-06-19 09:50:18 PDT
The Gtk port doesn't currently draw text shadows for text decorations such as underlines.
Comment 1 Jonathon Jongsma (jonner) 2008-06-19 13:36:48 PDT
Created attachment 21849 [details]
patch to implement drawing shadows for lines
Comment 2 Jonathon Jongsma (jonner) 2008-06-24 12:59:25 PDT
Created attachment 21914 [details]
Updated patch due to changes from bug #19727
Comment 3 Eric Seidel (no email) 2008-08-01 16:54:25 PDT
Comment on attachment 21914 [details]
Updated patch due to changes from bug #19727

Isn't "drawLineForText" used for drawing underlines?

Also this seems like kinda a gross hack.  But maybe this is the cleanest way to do this with Cairo.

Also, you don't respect Shadow-blur.  I think that we should come up with a better way of drawing Cairo shadows instead of this.

A shadow is a second copy of the entire image drawn at an offset and blurred.
Comment 4 Martin Robinson 2010-11-27 08:21:53 PST

*** This bug has been marked as a duplicate of bug 48074 ***