Bug 196357

Summary: [ iOS Sim ] REGRESSION (r242986) Layout Test storage/indexeddb/modern/idbtransaction-objectstore-failures-private.html is a flaky failure
Product: WebKit Reporter: Shawn Roberts <sroberts>
Component: Tools / TestsAssignee: Sihui Liu <sihui_liu>
Status: RESOLVED FIXED    
Severity: Normal CC: alecflett, beidson, commit-queue, ews-watchlist, ggaren, jsbell, lforschler, sihui_liu, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch for landing none

Description Shawn Roberts 2019-03-28 11:09:54 PDT
The following layout test is failing on iOS Simulator Release WK2

storage/indexeddb/modern/idbtransaction-objectstore-failures-private.html

Probable cause:

Test has been a flaky failure since test was created in https://trac.webkit.org/changeset/195394/webkit

However since changes in https://trac.webkit.org/changeset/242986/webkit . The test is showing up on iOS Simulator for the first time and failing more consistently. Test behavior is different in testing in r242985, and is less flaky in that revision. 

Reproduced with: 

run-webkit-tests storage/indexeddb/modern/idbtransaction-objectstore-failures-private.html --iterations 500 -f --ios-simulator

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=storage%2Findexeddb%2Fmodern%2Fidbtransaction-objectstore-failures-private.html

Diff:

--- /Volumes/Data/slave/ios-simulator-12-release-tests-wk2/build/layout-test-results/storage/indexeddb/modern/idbtransaction-objectstore-failures-private-expected.txt
+++ /Volumes/Data/slave/ios-simulator-12-release-tests-wk2/build/layout-test-results/storage/indexeddb/modern/idbtransaction-objectstore-failures-private-actual.txt
@@ -15,7 +15,7 @@
 Caught attempt to access non-existant object store on the transaction
 Caught attempt to access valid object store on a transaction that is already finishing
 put failed (because transaction was aborted)
-First version change transaction unexpected error - [object Event]
+First version change transaction abort
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 1 Radar WebKit Bug Importer 2019-03-28 11:12:06 PDT
<rdar://problem/49386836>
Comment 2 Shawn Roberts 2019-03-28 11:21:52 PDT
Marked flaky in https://trac.webkit.org/changeset/243612/webkit while waiting for a fix.
Comment 3 Sihui Liu 2019-04-25 10:01:21 PDT
Created attachment 368242 [details]
Patch
Comment 4 Geoffrey Garen 2019-04-25 12:58:01 PDT
Comment on attachment 368242 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=368242&action=review

r=me

> Source/WebCore/Modules/indexeddb/IDBTransaction.h:149
> +    bool isEventDispatched() const { return m_eventDispatched; }

Let's call this 

    bool didDispatchAbortOrCommit() const { return m_didDispatchAbortOrCommit; }
Comment 5 Sihui Liu 2019-04-25 18:18:16 PDT
Created attachment 368293 [details]
Patch for landing
Comment 6 WebKit Commit Bot 2019-04-25 18:58:38 PDT
Comment on attachment 368293 [details]
Patch for landing

Clearing flags on attachment: 368293

Committed r244674: <https://trac.webkit.org/changeset/244674>
Comment 7 WebKit Commit Bot 2019-04-25 18:58:40 PDT
All reviewed patches have been landed.  Closing bug.