Bug 19531

Summary: Profiling during a page load does not record a profile
Product: WebKit Reporter: Francisco Tolmasky <tolmasky>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben, bburg, cgriego, ddkilzer, rik
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   

Description Francisco Tolmasky 2008-06-12 23:07:47 PDT
On Firebug, one can hit "profile", then refresh to profile the load of a page.  On Safari the same steps result in a non-profile.
Comment 1 Anthony Ricaud 2008-06-13 02:46:13 PDT
I think this is a duplicate of bug 19246
Comment 2 Matt Lilek 2008-06-13 05:34:49 PDT

*** This bug has been marked as a duplicate of 19246 ***
Comment 3 Adam Roben (:aroben) 2008-06-13 09:22:29 PDT
I don't think this is exactly the same as bug 19426. Bug 19426 seems to be about having a new UI option to start profiling and automatically refresh the page. This bug is about profiling during a reload not working at all, regardless of whether we have a UI option for it.
Comment 4 Mark Rowe (bdash) 2008-06-13 14:56:39 PDT
<rdar://problem/6007136>
Comment 5 Anthony Ricaud 2008-06-13 15:00:17 PDT
(In reply to comment #3)
> I don't think this is exactly the same as bug 19426. Bug 19426 seems to be
> about having a new UI option to start profiling and automatically refresh the
> page. This bug is about profiling during a reload not working at all,
> regardless of whether we have a UI option for it.
> 

Oh yes, this is not exactly the same, my bad. This bug is useful and bug 19426 will help make it more discoverable.
Comment 6 BJ Burg 2014-01-26 12:34:08 PST
Timelines now auto-record for the first 10 or 20 seconds after page load start.