Bug 195022

Summary: [JSC] Make Intl fields lazily-allocated
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: New BugsAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED FIXED    
Severity: Normal CC: ews-watchlist, keith_miller, mark.lam, msaboff, sbarati, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch mark.lam: review+

Description Yusuke Suzuki 2019-02-25 16:05:11 PST
[JSC] Make Intl fields lazily-allocated
Comment 1 Yusuke Suzuki 2019-02-25 16:08:55 PST
Created attachment 362938 [details]
Patch
Comment 2 Yusuke Suzuki 2019-02-25 16:12:08 PST
Created attachment 362941 [details]
Patch
Comment 3 Mark Lam 2019-02-25 16:47:10 PST
Comment on attachment 362941 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=362941&action=review

r=me

> Source/JavaScriptCore/ChangeLog:10
> +        1. Make IntlObject fields including Intl.Collator lazily-alllocated because we already removed direct references from JS builtins to these constructors (@Collator etc.).

/alllocated/allocated/.
Comment 4 Yusuke Suzuki 2019-02-25 17:05:35 PST
Comment on attachment 362941 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=362941&action=review

>> Source/JavaScriptCore/ChangeLog:10
>> +        1. Make IntlObject fields including Intl.Collator lazily-alllocated because we already removed direct references from JS builtins to these constructors (@Collator etc.).
> 
> /alllocated/allocated/.

Oops, thanks.
Comment 5 Yusuke Suzuki 2019-02-25 18:13:25 PST
Committed r242064: <https://trac.webkit.org/changeset/242064>
Comment 6 Radar WebKit Bug Importer 2019-02-25 18:33:58 PST
<rdar://problem/48387136>
Comment 7 Yusuke Suzuki 2020-04-15 10:55:53 PDT
*** Bug 193549 has been marked as a duplicate of this bug. ***