Bug 19364

Summary: qtwebkit fails to render underlined links properly
Product: WebKit Reporter: Adys <adys.wh+webkit>
Component: WebKit QtAssignee: Adam Treat <manyoso>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
URL: http://testblog.blogspot.com/
Attachments:
Description Flags
Screenshot of behaviour
none
Reduced testcase
none
Fixes the underline issue for the Qt port and all ports for that matter hyatt: review+

Description Adys 2008-06-02 15:59:26 PDT
I'm not sure in which cases this is happening, but it always happens on the attached URL*. The second line of the hovered link in "Blog Archive > 2008 (1) > June (1) > This is a long enough title that wraps over two li..." doesn't correctly render under Arora. (See attached screenshot)
Since it works fine in Midori, I suppose it's qtwebkit-specific.

I've been getting a lot of problems with hover/underline in general actually - all wikipedia/wiki-defaultstyle links don't get a hover underline effect for example.


* http://adystest.blogspot.com/
Comment 1 Adys 2008-06-02 16:00:19 PDT
Created attachment 21471 [details]
Screenshot of behaviour
Comment 2 Adam Treat 2009-02-23 09:24:39 PST
I can reproduce.  Working on a simplified testcase as well as a fix.
Comment 3 Adam Treat 2009-02-23 10:02:48 PST
Created attachment 27884 [details]
Reduced testcase

This demonstrates the problem. 'foo' is underlined with a dotted line.  It should be a straight line.  Interestingly this only happens when the document is xhtml strict.
Comment 4 Adam Treat 2009-02-23 12:06:04 PST
Created attachment 27887 [details]
Fixes the underline issue for the Qt port and all ports for that matter
Comment 5 Adam Treat 2009-02-23 12:07:35 PST
This bug is essentially the same manifestation as this bug for the GTK port:

https://bugs.webkit.org/show_bug.cgi?id=15659
Comment 6 Dave Hyatt 2009-02-23 12:07:38 PST
Comment on attachment 27887 [details]
Fixes the underline issue for the Qt port and all ports for that matter

r=me
Comment 7 Adam Treat 2009-02-23 12:14:07 PST
Landed with r41152.