Bug 192047

Summary: Flaky Test: inspector/console/command-line-api.html
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: Tools / TestsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: drousso, joepeck, lforschler, ryanhaddad
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 50856    
Attachments:
Description Flags
Archive of layout-test-results from webkit-cq-02 none

Description WebKit Commit Bot 2018-11-27 15:57:20 PST
This is an automatically generated bug from the commit-queue.
inspector/console/command-line-api.html has been flaky on the commit-queue.

inspector/console/command-line-api.html was authored by drousso@apple.com and joepeck@webkit.org.
https://trac.webkit.org/browser/trunk/LayoutTests/inspector/console/command-line-api.html

The commit-queue just saw inspector/console/command-line-api.html flake (DumpRenderTree crashed) while processing attachment 355790 [details] on bug 191984.
Bot: webkit-cq-02  Port: <class 'webkitpy.common.config.ports.MacPort'>  Platform: Mac OS X 10.12.6

The bots will update this with information from each new failure.

If you believe this bug to be fixed or invalid, feel free to close.  The bots will re-open if the flake re-occurs.

If you would like to track this test fix with another bug, please close this bug as a duplicate.  The bots will follow the duplicate chain when making future comments.
Comment 1 WebKit Commit Bot 2018-11-27 15:57:22 PST
Created attachment 355802 [details]
Archive of layout-test-results from webkit-cq-02
Comment 2 Ryan Haddad 2018-11-28 09:57:16 PST
Thread 46 Crashed:: DFG Worklist Worker Thread
0   com.apple.JavaScriptCore      	0x00000001044d9c55 JSC::speculationFromValue(JSC::JSValue) + 213 (SpeculatedType.cpp:477)
1   com.apple.JavaScriptCore      	0x00000001044ad956 JSC::CodeBlock::valueProfilePredictionForBytecodeOffset(JSC::ConcurrentJSLocker const&, int) + 38 (SpeculatedType.h:473)
2   com.apple.JavaScriptCore      	0x00000001045b3357 JSC::DFG::ByteCodeParser::getPredictionWithoutOSRExit(unsigned int) + 343 (DFGByteCodeParser.cpp:876)
3   com.apple.JavaScriptCore      	0x00000001045a40e9 JSC::DFG::ByteCodeParser::Terminality JSC::DFG::ByteCodeParser::handleCall<JSC::OpTailCall>(JSC::Instruction const*, JSC::DFG::NodeType, JSC::CallMode) + 537 (DFGByteCodeParser.cpp:889)
4   com.apple.JavaScriptCore      	0x000000010459236e JSC::DFG::ByteCodeParser::parseBlock(unsigned int) + 3118 (Instruction.h:45)
5   com.apple.JavaScriptCore      	0x00000001045a742a JSC::DFG::ByteCodeParser::parseCodeBlock() + 810 (DFGByteCodeParser.cpp:7037)
6   com.apple.JavaScriptCore      	0x00000001045866c3 JSC::DFG::ByteCodeParser::handleCallVariant(JSC::DFG::Node*, JSC::VirtualRegister, JSC::CallVariant, int, JSC::VirtualRegister, int, unsigned int, JSC::InlineCallFrame::Kind, unsigned long long, unsigned int&, JSC::DFG::BasicBlock*, bool) + 5203 (Vector.h:1114)
7   com.apple.JavaScriptCore      	0x0000000104583fec JSC::DFG::ByteCodeParser::handleInlining(JSC::DFG::Node*, JSC::VirtualRegister, JSC::CallLinkStatus const&, int, JSC::VirtualRegister, int, unsigned int, JSC::DFG::NodeType, JSC::InlineCallFrame::Kind, unsigned long long) + 188 (DFGByteCodeParser.cpp:1916)
8   com.apple.JavaScriptCore      	0x0000000104583df2 JSC::DFG::ByteCodeParser::handleCall(JSC::VirtualRegister, JSC::DFG::NodeType, JSC::InlineCallFrame::Kind, unsigned int, JSC::DFG::Node*, int, int, JSC::CallLinkStatus, unsigned long long) + 386 (DFGByteCodeParser.cpp:1262)
9   com.apple.JavaScriptCore      	0x00000001045a3e3c JSC::DFG::ByteCodeParser::Terminality JSC::DFG::ByteCodeParser::handleCall<JSC::OpCall>(JSC::Instruction const*, JSC::DFG::NodeType, JSC::CallMode) + 604 (DFGByteCodeParser.cpp:1235)
10  com.apple.JavaScriptCore      	0x00000001045928dc JSC::DFG::ByteCodeParser::parseBlock(unsigned int) + 4508 (Instruction.h:45)
11  com.apple.JavaScriptCore      	0x00000001045a742a JSC::DFG::ByteCodeParser::parseCodeBlock() + 810 (DFGByteCodeParser.cpp:7037)
12  com.apple.JavaScriptCore      	0x00000001045a77c3 JSC::DFG::ByteCodeParser::parse() + 83 (DFGByteCodeParser.cpp:6852)
13  com.apple.JavaScriptCore      	0x00000001045a8928 JSC::DFG::parse(JSC::DFG::Graph&) + 392 (DFGByteCodeParser.cpp:93)
14  com.apple.JavaScriptCore      	0x000000010470cde2 JSC::DFG::Plan::compileInThreadImpl() + 338 (DFGPlan.cpp:251)
15  com.apple.JavaScriptCore      	0x000000010470c58b JSC::DFG::Plan::compileInThread(JSC::DFG::ThreadData*) + 619 (DFGPlan.cpp:188)
16  com.apple.JavaScriptCore      	0x0000000104759f95 JSC::DFG::Worklist::ThreadBody::work() + 277 (DumbPtrTraits.h:41)
17  com.apple.JavaScriptCore      	0x00000001040a973e WTF::Function<void ()>::CallableWrapper<WTF::AutomaticThread::start(WTF::AbstractLocker const&)::$_0>::call() + 334 (AutomaticThread.cpp:224)
18  com.apple.JavaScriptCore      	0x00000001040ead84 WTF::Thread::entryPoint(WTF::Thread::NewThreadContext*) + 212 (memory:2735)
19  com.apple.JavaScriptCore      	0x00000001040ec929 WTF::wtfThreadEntryPoint(void*) + 9 (ThreadingPthreads.cpp:203)
20  libsystem_pthread.dylib       	0x00007fff9c5ae93b _pthread_body + 180
21  libsystem_pthread.dylib       	0x00007fff9c5ae887 _pthread_start + 286
22  libsystem_pthread.dylib       	0x00007fff9c5ae08d thread_start + 13
Comment 3 Alexey Proskuryakov 2018-12-01 16:06:39 PST

*** This bug has been marked as a duplicate of bug 192050 ***