Bug 191935

Summary: [ews-app] Add support to communicate with Buildbot
Product: WebKit Reporter: Aakash Jain <aakash_jain>
Component: Tools / TestsAssignee: Aakash Jain <aakash_jain>
Status: RESOLVED FIXED    
Severity: Normal CC: aakash_jain, ap, kocsen_chung, lforschler, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Proposed patch lforschler: review+

Description Aakash Jain 2018-11-23 17:57:32 PST
ews-app needs to send patches to Buildbot using 'buildbot try' command. We should add that feature.
Comment 1 Aakash Jain 2018-11-23 19:06:20 PST
Created attachment 355550 [details]
Proposed patch

Part of patch series. Therefore wouldn't apply to ToT without applying other patches first.
Comment 2 Lucas Forschler 2018-11-26 12:51:04 PST
Comment on attachment 355550 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355550&action=review

> Tools/BuildSlaveSupport/ews-app/ews/common/buildbot.py:44
> +            _log.warn('Error in executing: {}, rc={}'.format(command, return_code))

This should be:
Error executing:
or
Error while executing:
Comment 3 Kocsen Chung 2018-11-26 14:59:56 PST
Comment on attachment 355550 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355550&action=review

> Tools/BuildSlaveSupport/ews-app/ews/common/buildbot.py:35
> +        command = ['buildbot', 'try', '--connect=pb', '--master={}:{}'.format(config.BUG_SERVER_HOST, config.BUILDBOT_SERVER_PORT),

nit:
Have every `--flag [param]` pair be in it's own new line for readability.

>> Tools/BuildSlaveSupport/ews-app/ews/common/buildbot.py:44
>> +            _log.warn('Error in executing: {}, rc={}'.format(command, return_code))
> 
> This should be:
> Error executing:
> or
> Error while executing:

nit: spell out `rc` => `return code` and have it be on a new line.
Comment 4 Aakash Jain 2018-11-26 17:08:26 PST
> nit:
> Have every `--flag [param]` pair be in it's own new line for readability.
Sure.

> nit: spell out `rc` => `return code`
Done

> and have it be on a new line.
Tried with and without new line, having on same line seems more readable.

> > This should be:
> > Error executing:
Changed.
Comment 5 Aakash Jain 2018-11-26 17:09:21 PST
Committed r238535: <http://trac.webkit.org/changeset/238535>
Comment 6 Radar WebKit Bug Importer 2018-11-26 17:10:59 PST
<rdar://problem/46262314>