Bug 190510

Summary: Web Inspector: Dark Mode: Highlight text in Network Headers search is too dark
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Joseph Pecoraro <joepeck>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, hi, inspector-bugzilla-changes, joepeck, nvasilyev, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[PATCH] Proposed Fix none

Description Joseph Pecoraro 2018-10-11 20:14:15 PDT
Web Inspector: Dark Mode: Highlight text in Network Headers search is too dark

Steps to Reproduce:
•. Use Dark Mode
1. Inspect this page
2. Show Network Tab
3. Select a Resource
4. Show Headers Pane
5. ⌘F to search for a string
  => Highlights look bad
Comment 1 Joseph Pecoraro 2018-10-11 20:15:05 PDT
Created attachment 352129 [details]
[PATCH] Proposed Fix
Comment 2 Devin Rousso 2018-10-11 22:27:38 PDT
Comment on attachment 352129 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=352129&action=review

r=me

> Source/WebInspectorUI/UserInterface/Views/ResourceHeadersContentView.css:82
> +    color: var(--text-color);

It seems weird to me that we'd color the header keys too (instead of using the existing current color) , but I suppose that blue-on-yellow isn't much better :|

If we did, you could drop this `color` altogether, since the `.value` already uses `--text-color`.
Comment 3 Nikita Vasilyev 2018-10-12 12:05:51 PDT
I don't think I even knew that there's search in the headers pane.

This fix is fine. Eventually, I'd like to unify highlight styles. Search highlights are used in DOM tree outline, styles sidebar, resource content view, console, search tab, and a few other places. We should make them look the same and, possibly, even use the same CSS rule everywhere.
Comment 4 WebKit Commit Bot 2018-10-12 15:59:55 PDT
Comment on attachment 352129 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 352129

Committed r237085: <https://trac.webkit.org/changeset/237085>
Comment 5 WebKit Commit Bot 2018-10-12 15:59:57 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2018-10-12 16:01:03 PDT
<rdar://problem/45240487>