Bug 189778

Summary: [JSC] Enable LLInt ASM interpreter on X64 and ARM64 in non JIT configuration
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: JavaScriptCoreAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED FIXED    
Severity: Normal CC: ews-watchlist, fpizlo, keith_miller, mark.lam, msaboff, saam, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch
none
Patch
keith_miller: review+
Patch
none
Patch none

Description Yusuke Suzuki 2018-09-19 22:46:13 PDT
LLInt ASM interpreter is 2x faster than CLoop interpreter.
We would like to enable it for non JIT configuration in x64 and ARM64.

I don't consider enabling this for the other CPU architectures now since no buildbot exists for non JIT configurations.
Comment 2 Yusuke Suzuki 2018-09-19 22:49:15 PDT
Created attachment 350170 [details]
Patch
Comment 3 Yusuke Suzuki 2018-09-21 02:00:17 PDT
Created attachment 350338 [details]
Patch
Comment 4 EWS Watchlist 2018-09-21 02:01:51 PDT
Attachment 350338 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 56 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Yusuke Suzuki 2018-09-21 02:12:05 PDT
Created attachment 350340 [details]
Patch
Comment 6 EWS Watchlist 2018-09-21 02:15:10 PDT
Attachment 350340 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 57 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Yusuke Suzuki 2018-09-21 02:31:47 PDT
Created attachment 350342 [details]
Patch
Comment 8 EWS Watchlist 2018-09-21 02:34:27 PDT
Attachment 350342 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 58 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 9 Yusuke Suzuki 2018-09-21 06:56:16 PDT
Created attachment 350355 [details]
Patch
Comment 10 EWS Watchlist 2018-09-21 06:58:18 PDT
Attachment 350355 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 58 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 11 Keith Miller 2018-09-21 10:37:54 PDT
Comment on attachment 350355 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=350355&action=review

r=me with some nits.

> Source/JavaScriptCore/ChangeLog:10
> +        configuration in X86_64 and ARM64.

Nit: configurations

> Source/JavaScriptCore/ChangeLog:12
> +        This patch enables LLInt for non JIT in X86_64 and ARM64 architectures.

Nit: maybe "for non JIT in" => "for non JIT builds on"

> Source/JavaScriptCore/ChangeLog:14
> +        configuration. But it is wrong in the new scenario since we have a buildx

typo: "buildx" => "build"?

> Source/JavaScriptCore/jit/HostCallReturnValue.cpp:-38
> -// Nothing to see here.

Lol solid comment.
Comment 12 Yusuke Suzuki 2018-09-21 19:46:53 PDT
Comment on attachment 350355 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=350355&action=review

Thank you!

>> Source/JavaScriptCore/ChangeLog:10
>> +        configuration in X86_64 and ARM64.
> 
> Nit: configurations

Fixed.

>> Source/JavaScriptCore/ChangeLog:12
>> +        This patch enables LLInt for non JIT in X86_64 and ARM64 architectures.
> 
> Nit: maybe "for non JIT in" => "for non JIT builds on"

Fixed.

>> Source/JavaScriptCore/ChangeLog:14
>> +        configuration. But it is wrong in the new scenario since we have a buildx
> 
> typo: "buildx" => "build"?

Fixed.
Comment 13 Yusuke Suzuki 2018-09-21 19:55:47 PDT
Created attachment 350480 [details]
Patch
Comment 14 Yusuke Suzuki 2018-09-21 20:02:55 PDT
Created attachment 350482 [details]
Patch
Comment 15 EWS Watchlist 2018-09-21 20:02:57 PDT
Attachment 350480 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 57 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 16 EWS Watchlist 2018-09-21 20:23:35 PDT
Attachment 350482 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 57 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 17 Yusuke Suzuki 2018-09-21 22:26:50 PDT
Committed r236381: <https://trac.webkit.org/changeset/236381>
Comment 18 Radar WebKit Bug Importer 2018-09-21 22:27:22 PDT
<rdar://problem/44701303>