Bug 186233

Summary: [ESNext][BigInt] Implement support for "<<" and ">>"
Product: WebKit Reporter: Caio Lima <ticaiolima>
Component: JavaScriptCoreAssignee: Caio Lima <ticaiolima>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, ews-watchlist, keith_miller, mark.lam, msaboff, sbarati, webkit-bug-importer, ysuzuki
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 190836    
Bug Blocks: 179001, 192017    
Attachments:
Description Flags
WIP - Patch
none
WIP - Patch
none
WIP - Patch
none
Patch none

Description Caio Lima 2018-06-02 06:52:38 PDT
...
Comment 1 Caio Lima 2018-10-23 19:36:18 PDT
Created attachment 353017 [details]
WIP - Patch
Comment 2 EWS Watchlist 2018-10-23 19:39:31 PDT
Attachment 353017 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/JSBigInt.cpp:1244:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
ERROR: Source/JavaScriptCore/runtime/JSBigInt.cpp:1319:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Total errors found: 2 in 14 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Caio Lima 2018-10-24 05:20:08 PDT
*** Bug 186232 has been marked as a duplicate of this bug. ***
Comment 4 Caio Lima 2018-11-07 07:28:48 PST
Created attachment 354092 [details]
WIP - Patch
Comment 5 Caio Lima 2018-11-07 07:29:20 PST
Comment on attachment 354092 [details]
WIP - Patch

Rebased with master
Comment 6 Caio Lima 2018-11-14 09:20:27 PST
Created attachment 354818 [details]
WIP - Patch
Comment 7 Caio Lima 2018-11-27 17:39:19 PST
Created attachment 355827 [details]
Patch
Comment 8 Yusuke Suzuki 2018-12-02 00:06:06 PST
Comment on attachment 355827 [details]
Patch

r=me
Comment 9 Caio Lima 2018-12-02 08:42:20 PST
Comment on attachment 355827 [details]
Patch

Thank you very much for the review!
Comment 10 WebKit Commit Bot 2018-12-02 09:08:53 PST
Comment on attachment 355827 [details]
Patch

Clearing flags on attachment: 355827

Committed r238790: <https://trac.webkit.org/changeset/238790>
Comment 11 WebKit Commit Bot 2018-12-02 09:08:54 PST
All reviewed patches have been landed.  Closing bug.
Comment 12 Radar WebKit Bug Importer 2018-12-02 09:09:26 PST
<rdar://problem/46403139>