Bug 182508

Summary: REGRESSION(r227964): These introduced an API test failure with URLTest.HostIsIPAddress alongside commit r228086 (Requested by mlewis13 on #webkit).
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: New BugsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED FIXED    
Severity: Normal CC: cgarcia, jlewis3, mcatanzaro, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 182328    
Attachments:
Description Flags
ROLLOUT of r227964 none

Description WebKit Commit Bot 2018-02-05 14:00:07 PST
https://trac.webkit.org/changeset/227964 broke the build:
These introduced an API test  failure with URLTest.HostIsIPAddress alongside commit r228086 (Requested by mlewis13 on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2018-02-05 14:00:12 PST
Created attachment 333120 [details]
ROLLOUT of r227964

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Matt Lewis 2018-02-05 14:01:03 PST
Comment on attachment 333120 [details]
ROLLOUT of r227964

Clearing flags on attachment: 333120

Committed r228123: <https://trac.webkit.org/changeset/228123>
Comment 3 Matt Lewis 2018-02-05 14:01:04 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2018-02-05 14:02:24 PST
<rdar://problem/37249303>