Bug 182088

Summary: Make run-perf-tests work with Speedometer 2.0 and re-enable the tests
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: Tools / TestsAssignee: Ryosuke Niwa <rniwa>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, commit-queue, koivisto, lforschler, ryanhaddad, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=182322
Bug Depends on: 182089    
Bug Blocks:    
Attachments:
Description Flags
Patch koivisto: review+, commit-queue: commit-queue-

Description Ryosuke Niwa 2018-01-25 00:59:02 PST
Make the new score computation reflected in run-perf-tests and unskip the test.
Comment 1 Ryosuke Niwa 2018-01-25 01:05:47 PST
Created attachment 332237 [details]
Patch
Comment 2 Ryosuke Niwa 2018-01-25 01:06:10 PST
Unfortunately, we can't land this patch until we fix perf dashboard as well.
Comment 3 Ryosuke Niwa 2018-01-25 01:08:13 PST
Comment on attachment 332237 [details]
Patch

As such, we can't land this patch. Landing this patch would prevent all test results from being processed in the perf dashboard.
Comment 4 Radar WebKit Bug Importer 2018-01-25 01:15:10 PST
<rdar://problem/36859067>
Comment 5 Ryosuke Niwa 2018-01-29 17:38:33 PST
We actually need this fix for StyleBench as well.
Comment 6 Ryan Haddad 2018-02-05 21:24:29 PST
*** Bug 182079 has been marked as a duplicate of this bug. ***
Comment 7 WebKit Commit Bot 2018-02-09 21:22:51 PST
Comment on attachment 332237 [details]
Patch

Rejecting attachment 332237 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-02', 'apply-attachment', '--no-update', '--non-interactive', 332237, '--port=mac']" exit_code: 2 cwd: /Volumes/Data/EWS/WebKit

Last 500 characters of output:
ile PerformanceTests/resources/results-template.html
Hunk #1 FAILED at 227.
1 out of 1 hunk FAILED -- saving rejects to file PerformanceTests/resources/results-template.html.rej
patching file PerformanceTests/resources/runner.js
Hunk #1 FAILED at 223.
1 out of 1 hunk FAILED -- saving rejects to file PerformanceTests/resources/runner.js.rej

Failed to run "[u'/Volumes/Data/EWS/WebKit/Tools/Scripts/svn-apply', '--force', '--reviewer', u'Antti Koivisto']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

Full output: http://webkit-queues.webkit.org/results/6442748
Comment 8 Ryosuke Niwa 2018-02-09 22:14:54 PST
Committed r228361: <https://trac.webkit.org/changeset/228361>