Bug 181619

Summary: [iOS] Remove unneeded accessibility-related sandbox rules
Product: WebKit Reporter: Brent Fulgham <bfulgham>
Component: WebKit2Assignee: Brent Fulgham <bfulgham>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, eric.carlson, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 190019    
Attachments:
Description Flags
Patch eric.carlson: review+

Description Brent Fulgham 2018-01-12 15:49:35 PST
A number of accessibility features are enabled by the WebContent process sandbox. These aren't needed, because Safari is the application that actually handles the accessibility user interface.

After reviewing with the AX team, we have identified a number of symbols and endpoints we can remove.
Comment 1 Radar WebKit Bug Importer 2018-01-12 15:50:19 PST
<rdar://problem/36485356>
Comment 2 Brent Fulgham 2018-01-12 15:53:27 PST
Created attachment 331247 [details]
Patch
Comment 3 Brent Fulgham 2018-01-12 16:24:07 PST
I've run this revised profile locally and confirmed VoiceOver works properly in WebContent.
Comment 4 Eric Carlson 2018-01-12 16:25:48 PST
Comment on attachment 331247 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=331247&action=review

> Source/WebKit/ChangeLog:10
> +        not needed in the WebContent process, since 

Nit: since what?
Comment 5 Brent Fulgham 2018-01-12 16:26:26 PST
Comment on attachment 331247 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=331247&action=review

>> Source/WebKit/ChangeLog:10
>> +        not needed in the WebContent process, since 
> 
> Nit: since what?

Ack!
Comment 6 Brent Fulgham 2018-01-12 16:28:14 PST
Committed r226926: <https://trac.webkit.org/changeset/226926>