Bug 178818

Summary: REGRESSION(r222945): "It made WasmBench crash" (Requested by saamyjoon on #webkit).
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: New BugsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED FIXED    
Severity: Normal CC: fpizlo, jlewis3, msaboff, sbarati, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 177839    
Attachments:
Description Flags
ROLLOUT of r222945 none

Description WebKit Commit Bot 2017-10-25 11:30:16 PDT
https://trac.webkit.org/changeset/222945 broke the build:
"It made WasmBench crash" (Requested by saamyjoon on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2017-10-25 11:30:22 PDT
Created attachment 324857 [details]
ROLLOUT of r222945

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Commit Bot 2017-10-25 11:32:49 PDT
Comment on attachment 324857 [details]
ROLLOUT of r222945

Clearing flags on attachment: 324857

Committed r223965: <https://trac.webkit.org/changeset/223965>
Comment 3 WebKit Commit Bot 2017-10-25 11:32:51 PDT
All reviewed patches have been landed.  Closing bug.
Comment 4 Filip Pizlo 2017-10-25 12:25:43 PDT
(In reply to WebKit Commit Bot from comment #0)
> https://trac.webkit.org/changeset/222945 broke the build:
> "It made WasmBench crash" (Requested by saamyjoon on #webkit).
> 
> This is an automatic bug report generated by webkitbot. If this bug
> report was created because of a flaky test, please file a bug for the flaky
> test (if we don't already have one on file) and dup this bug against that bug
> so that we can track how often these flaky tests fail.

It would be super helpful if you could post the crash trace when rolling out a patch because of a crash.
Comment 5 Saam Barati 2017-10-25 12:32:40 PDT
(In reply to Filip Pizlo from comment #4)
> (In reply to WebKit Commit Bot from comment #0)
> > https://trac.webkit.org/changeset/222945 broke the build:
> > "It made WasmBench crash" (Requested by saamyjoon on #webkit).
> > 
> > This is an automatic bug report generated by webkitbot. If this bug
> > report was created because of a flaky test, please file a bug for the flaky
> > test (if we don't already have one on file) and dup this bug against that bug
> > so that we can track how often these flaky tests fail.
> 
> It would be super helpful if you could post the crash trace when rolling out
> a patch because of a crash.

attached it to:
https://bugs.webkit.org/show_bug.cgi?id=177839
Comment 6 Saam Barati 2017-10-25 14:33:54 PDT
*** Bug 178755 has been marked as a duplicate of this bug. ***
Comment 7 Radar WebKit Bug Importer 2017-11-15 12:44:34 PST
<rdar://problem/35568067>