Bug 177792

Summary: A JSFunction's ObjectAllocationProfile should watch the poly prototype watchpoint so it can clear its object allocation profile
Product: WebKit Reporter: Saam Barati <saam>
Component: JavaScriptCoreAssignee: Saam Barati <saam>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, commit-queue, fpizlo, ggaren, gskachkov, jfbastien, keith_miller, mark.lam, msaboff, rmorisset, ticaiolima, webkit-bug-importer, ysuzuki
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch
ysuzuki: review+
patch for landing none

Description Saam Barati 2017-10-02 16:11:49 PDT
...
Comment 1 Saam Barati 2017-10-10 19:03:41 PDT
patch forthcoming
Comment 2 Saam Barati 2017-10-10 19:59:19 PDT
Created attachment 323373 [details]
patch
Comment 3 Yusuke Suzuki 2017-10-12 01:13:18 PDT
Comment on attachment 323373 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323373&action=review

r=me

> Source/JavaScriptCore/runtime/FunctionRareData.h:114
> +    class ClearAllocationProfile : public Watchpoint {

How about naming it ClearAllocationProfileWatchpoint?
Comment 4 Saam Barati 2017-11-08 10:58:20 PST
Thanks for the review. I forgot about this patch. Will land it today with your naming suggestion.
Comment 5 Saam Barati 2017-11-08 14:12:19 PST
Comment on attachment 323373 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323373&action=review

>> Source/JavaScriptCore/runtime/FunctionRareData.h:114
>> +    class ClearAllocationProfile : public Watchpoint {
> 
> How about naming it ClearAllocationProfileWatchpoint?

I'm actually thinking that "AllocationProfileClearingWatchpoint" is a better name and more in line with our other names, like, StructureStubInfoClearingWatchpoint.
Comment 6 Saam Barati 2017-11-08 14:17:52 PST
Created attachment 326372 [details]
patch for landing
Comment 7 WebKit Commit Bot 2017-11-08 15:38:59 PST
Comment on attachment 326372 [details]
patch for landing

Clearing flags on attachment: 326372

Committed r224603: <https://trac.webkit.org/changeset/224603>
Comment 8 WebKit Commit Bot 2017-11-08 15:39:00 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Yusuke Suzuki 2017-11-08 17:57:09 PST
Comment on attachment 323373 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=323373&action=review

>>> Source/JavaScriptCore/runtime/FunctionRareData.h:114
>>> +    class ClearAllocationProfile : public Watchpoint {
>> 
>> How about naming it ClearAllocationProfileWatchpoint?
> 
> I'm actually thinking that "AllocationProfileClearingWatchpoint" is a better name and more in line with our other names, like, StructureStubInfoClearingWatchpoint.

That sounds nice!
Comment 10 Radar WebKit Bug Importer 2017-11-15 09:43:06 PST
<rdar://problem/35562300>