Bug 172641

Summary: [ARM64] REGRESSION(r217386-r217466): It made ~50 JSC tests fail
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: clopez, keith_miller, mark.lam, msaboff, ossy, sbarati, ysuzuki
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 108645    

Description Csaba Osztrogonác 2017-05-26 04:05:45 PDT
last known good revision:
- https://trac.webkit.org/changeset/217432
- 21 failures
- https://build.webkit.org/builders/JSCOnly%20Linux%20AArch64%20Release/builds/825

first bad revision:
- https://trac.webkit.org/changeset/217467
- 75 failures
- https://build.webkit.org/builders/JSCOnly%20Linux%20AArch64%20Release/builds/845

Unfortunately the build was broken between these revisions,
because https://trac.webkit.org/changeset/217438 broke it
and only https://trac.webkit.org/changeset/217467 fixed it.

JSC changes between these revisions:
- https://trac.webkit.org/changeset/217458/webkit
- https://trac.webkit.org/changeset/217457/webkit
- https://trac.webkit.org/changeset/217438/webkit

note: I just reported this regression, I have no plan (and time) to fix or help fixing this regression.
Comment 1 Yusuke Suzuki 2017-05-26 04:07:30 PDT
For Date things, we are tracking in https://bugs.webkit.org/show_bug.cgi?id=172637
Comment 2 Csaba Osztrogonác 2017-05-26 04:11:10 PDT
(In reply to Yusuke Suzuki from comment #1)
> For Date things, we are tracking in
> https://bugs.webkit.org/show_bug.cgi?id=172637

Thanks, it seems it is a dup of bug172637.

*** This bug has been marked as a duplicate of bug 172637 ***