Bug 171270

Summary: [GTK] Add libgpg-error, libgcrypt libraries to JHBuild
Product: WebKit Reporter: Zan Dobersek <zan>
Component: New BugsAssignee: Zan Dobersek <zan>
Status: RESOLVED FIXED    
Severity: Normal CC: mcatanzaro
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch mcatanzaro: review+, mcatanzaro: commit-queue-

Description Zan Dobersek 2017-04-25 05:14:54 PDT
[GTK] Add libgpg-error, libgcrypt libraries to JHBuild
Comment 1 Zan Dobersek 2017-04-25 05:17:06 PDT
Created attachment 308094 [details]
Patch
Comment 2 Zan Dobersek 2017-04-25 07:06:16 PDT
Created attachment 308098 [details]
Patch
Comment 3 Michael Catanzaro 2017-04-25 07:15:33 PDT
Comment on attachment 308098 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=308098&action=review

> Tools/ChangeLog:20
> +2017-04-25  Zan Dobersek  <zdobersek@igalia.com>
> +
> +        [GTK] Add libgpg-error, libgcrypt libraries to JHBuild
> +        https://bugs.webkit.org/show_bug.cgi?id=171270
> +
> +        Reviewed by NOBODY (OOPS!).

Remove this duplicate changelog entry!

> Tools/gtk/jhbuild.modules:621
> +    <dependencies>
> +      <dep package="libgpg-error"/>
> +    </dependencies>

Style: put the branch tag first, then the dependencies tag next.

> Tools/gtk/patches/libgcrypt-use-only-dev-urandom-for-testing.patch:12
> ++  // Enforce the use of /dev/urandom for testing of the libgcrypt-based
> ++  // Web Crypto implementation testing in WebKit.
> ++  // DO NOT USE THIS PATCH OUTSIDE OF TESTING ENVIRONMENTS.
> ++  level = 0;

Nice!
Comment 4 Zan Dobersek 2017-04-25 09:46:02 PDT
Committed r215739: <http://trac.webkit.org/changeset/215739>