Bug 170960

Summary: [mac-wk2] LayoutTest fast/mediastream/getUserMedia-webaudio.html is a flaky timeout
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: MediaAssignee: Matt Lewis <jlewis3>
Status: RESOLVED FIXED    
Severity: Normal CC: amir_mark, eric.carlson, ews-watchlist, glenn, hta, Jenner, jer.noble, jlewis3, philipj, sergio, tommyw, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Comment 1 Matt Lewis 2017-05-01 15:06:56 PDT
Created attachment 308771 [details]
Patch
Comment 2 Ryan Haddad 2017-05-01 15:13:20 PDT
Comment on attachment 308771 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=308771&action=review

> LayoutTests/platform/mac-wk2/TestExpectations:659
> +webkit.org/b/170960 fast/mediastream/getUserMedia-webaudio.html [ Pass Timeout ]

Add [ Sierra ] in front of the test name since this is only a flaky timeout there. Otherwise, this looks good.
Comment 3 Matt Lewis 2017-05-01 15:27:40 PDT
Created attachment 308776 [details]
Patch
Comment 4 Ryan Haddad 2017-05-01 15:29:29 PDT
Comment on attachment 308776 [details]
Patch

Clearing flags on attachment: 308776

Committed r216036: <http://trac.webkit.org/changeset/216036>
Comment 5 Ryan Haddad 2017-05-01 15:29:30 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Ryan Haddad 2017-05-01 15:29:51 PDT
(In reply to Ryan Haddad from comment #5)
> All reviewed patches have been landed.  Closing bug.

Reopening because this is just marking the test as flaky.
Comment 7 Matt Lewis 2017-05-18 15:15:04 PDT
El Capitan is now starting to timeout on the release build.

Unable to reproduce the issue locally.
Comment 8 Matt Lewis 2017-05-18 15:15:23 PDT
(In reply to Matt Lewis from comment #7)
> El Capitan is now starting to timeout on the release build.
> 
> Unable to reproduce the issue locally.

https://build.webkit.org/results/Apple%20El%20Capitan%20Release%20WK2%20(Tests)/r217063%20(1646)/results.html
Comment 9 Amir Mark Jr 2021-02-15 13:20:42 PST
Issue is still occurring on Big Sur WK2 and Catalina WK2. 

https://results.webkit.org/?suite=layout-tests&test=fast%2Fmediastream%2FgetUserMedia-webaudio.html

Was able to reproduce locally using:

run-webkit-tests fast/mediastream/getUserMedia-webaudio.html --iterations 1000 -f
Comment 10 Robert Jenner 2021-03-30 19:22:08 PDT
Re-updated test expectations to include Failure here:
https://trac.webkit.org/changeset/275257/webkit
Comment 11 youenn fablet 2021-04-19 09:39:20 PDT
Created attachment 426436 [details]
Patch
Comment 12 youenn fablet 2021-04-19 09:39:40 PDT
<rdar://74158395>
Comment 13 EWS 2021-04-19 14:10:30 PDT
Committed r276273 (236755@main): <https://commits.webkit.org/236755@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 426436 [details].