Bug 170894

Summary: RTCPeerConnection addTrack does not require a stream parameter
Product: WebKit Reporter: youenn fablet <youennf>
Component: WebCore Misc.Assignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, commit-queue
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description youenn fablet 2017-04-16 15:43:00 PDT
RTCPeerConnection addTrack does not require a stream parameter as per the spec and https://github.com/w3c/webrtc-pc/issues/288
Comment 1 youenn fablet 2017-04-16 15:44:05 PDT
Created attachment 307243 [details]
Patch
Comment 2 youenn fablet 2017-04-16 15:44:59 PDT
(In reply to youenn fablet from comment #1)
> Created attachment 307243 [details]
> Patch

Playing the stream before it gets the second track is changing the results.
Probably worth investigating that further.
Comment 3 Alex Christensen 2017-04-17 00:09:50 PDT
Comment on attachment 307243 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=307243&action=review

> LayoutTests/webrtc/video-addTrack-expected.txt:10
> +FAIL Testing image result, wait = false The index is not in the allowed range.

Let's make this not say FAIL if it's the intended behavior.
Comment 4 youenn fablet 2017-04-17 07:59:45 PDT
Thanks for the review

(In reply to Alex Christensen from comment #3)
> Comment on attachment 307243 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=307243&action=review
> 
> > LayoutTests/webrtc/video-addTrack-expected.txt:10
> > +FAIL Testing image result, wait = false The index is not in the allowed range.
> 
> Let's make this not say FAIL if it's the intended 

Will need to check with Eric but I am not sure this is the expected behavior.
Comment 5 WebKit Commit Bot 2017-04-17 08:27:44 PDT
Comment on attachment 307243 [details]
Patch

Clearing flags on attachment: 307243

Committed r215412: <http://trac.webkit.org/changeset/215412>
Comment 6 WebKit Commit Bot 2017-04-17 08:27:45 PDT
All reviewed patches have been landed.  Closing bug.