Bug 169892

Summary: WebAssembly: WasmMemory::lastAllocatedMemoryMode is racy
Product: WebKit Reporter: JF Bastien <jfbastien>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: fpizlo, jfbastien, keith_miller, mark.lam, msaboff, sbarati
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=170628
Bug Depends on:    
Bug Blocks: 159775    

Description JF Bastien 2017-03-20 14:11:22 PDT
It's a benign race... but you can create two Workers, use wasm, and they clobber the value independently.

I'm not sure TLS is the best thing either. Having the VM may be better?
Comment 1 JF Bastien 2017-03-20 14:15:24 PDT
Same for allocatedFastMemories, though this one is less benign.
Comment 2 JF Bastien 2017-04-07 17:13:28 PDT

*** This bug has been marked as a duplicate of bug 170628 ***