Bug 165942

Summary: i64.eqz should use an Int64 zero
Product: WebKit Reporter: Keith Miller <keith_miller>
Component: New BugsAssignee: Keith Miller <keith_miller>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, mark.lam, msaboff, saam
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Keith Miller 2016-12-15 19:32:21 PST
i64.eqz should use an Int64 zero
Comment 1 Keith Miller 2016-12-15 20:10:55 PST
Created attachment 297293 [details]
Patch
Comment 2 WebKit Commit Bot 2016-12-15 20:12:44 PST
This patch modifies one of the wasm.json files. Please ensure that any changes in one have been mirrored to the other. You can find the wasm.json files at "Source/JavaScriptCore/wasm/wasm.json" and "JSTests/wasm/wasm.json".
Comment 3 Mark Lam 2016-12-15 20:50:36 PST
Comment on attachment 297293 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=297293&action=review

r=me with suggested change.

> Source/JavaScriptCore/wasm/generateWasmOpsHeader.py:268
> +inline const char* makeString(OpType op)

I think "opName" would be a better name than "makeString".
Comment 4 Keith Miller 2016-12-16 09:18:14 PST
Comment on attachment 297293 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=297293&action=review

>> Source/JavaScriptCore/wasm/generateWasmOpsHeader.py:268
>> +inline const char* makeString(OpType op)
> 
> I think "opName" would be a better name than "makeString".

I chose makeString because it works with the new WasmParser.h failure template code.
Comment 5 WebKit Commit Bot 2016-12-16 09:54:03 PST
Comment on attachment 297293 [details]
Patch

Clearing flags on attachment: 297293

Committed r209923: <http://trac.webkit.org/changeset/209923>
Comment 6 WebKit Commit Bot 2016-12-16 09:54:07 PST
All reviewed patches have been landed.  Closing bug.