Bug 165451

Summary: Cleanup: Rename some HTTP 0.9-specific functions to conform to WebKit Code Style Guidelines
Product: WebKit Reporter: Daniel Bates <dbates>
Component: WebCore Misc.Assignee: Daniel Bates <dbates>
Severity: Normal CC: cdumez, commit-queue, esprehn+autocc, kangil.han
Priority: P2    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Description Flags
Patch none

Description Daniel Bates 2016-12-05 18:42:54 PST
The functions Document::shouldEnforceHTTP0_9Sandbox() and ResourceResponseBase::isHttpVersion0_9() do not conform the naming conventions in the WebKit Code Style Guidelines. We should rename them so that they conform to the guidelines and are more consistent with the rest of the codebase.
Comment 1 Daniel Bates 2016-12-05 18:49:26 PST
Created attachment 296244 [details]

I chose to standardize on the substring "HTTP09" in the names of these functions. Would "HTTPVersion09" be more understandable? I am open to naming suggestions.
Comment 2 Daniel Bates 2016-12-06 09:47:15 PST
Comment on attachment 296244 [details]

Clearing flags on attachment: 296244

Committed r209403: <http://trac.webkit.org/changeset/209403>
Comment 3 Daniel Bates 2016-12-06 09:47:19 PST
All reviewed patches have been landed.  Closing bug.