Bug 164965

Summary: Convert IntersectionObserver over to using RuntimeEnabledFeatures so it can be properly excluded from script
Product: WebKit Reporter: Sam Weinig <sam>
Component: New BugsAssignee: Sam Weinig <sam>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, cdumez, commit-queue, esprehn+autocc, keith_miller, kondapallykalyan, mark.lam, msaboff, ossy, ryanhaddad, sbarati, simon.fraser
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description Sam Weinig 2016-11-18 15:48:37 PST
Convert IntersectionObserver over to using RuntimeEnabledFeatures so it can be properly excluded from script
Comment 1 Sam Weinig 2016-11-18 16:32:18 PST
Created attachment 295216 [details]
Patch
Comment 2 Sam Weinig 2016-11-18 16:47:56 PST
Created attachment 295222 [details]
Patch
Comment 3 Simon Fraser (smfr) 2016-11-26 15:39:26 PST
Created attachment 295443 [details]
Patch
Comment 4 WebKit Commit Bot 2016-11-26 15:40:45 PST
Attachment 295443 [details] did not pass style-queue:


ERROR: Tools/DumpRenderTree/TestOptions.mm:29:  Streams are highly discouraged.  [readability/streams] [3]
Total errors found: 1 in 27 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 WebKit Commit Bot 2016-11-26 20:22:06 PST
Comment on attachment 295443 [details]
Patch

Clearing flags on attachment: 295443

Committed r208983: <http://trac.webkit.org/changeset/208983>
Comment 6 WebKit Commit Bot 2016-11-26 20:22:11 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Csaba Osztrogon√°c 2016-11-26 23:25:55 PST
(In reply to comment #5)
> Comment on attachment 295443 [details]
> Patch
> 
> Clearing flags on attachment: 295443
> 
> Committed r208983: <http://trac.webkit.org/changeset/208983>

It broke the Apple Mac cmake build, see build.webkit.org for details.
Comment 8 Simon Fraser (smfr) 2016-11-26 23:34:27 PST
Attempted a fix in https://trac.webkit.org/changeset/208987
Comment 9 Ryan Haddad 2016-11-27 20:16:05 PST
(In reply to comment #5)
> Comment on attachment 295443 [details]
> Patch
> 
> Clearing flags on attachment: 295443
> 
> Committed r208983: <http://trac.webkit.org/changeset/208983>

The LayoutTest edited with this change is failing on macOS and iOS WK2:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=intersection-observer%2Fintersection-observer-entry-interface.html
Comment 10 Simon Fraser (smfr) 2016-11-27 23:20:03 PST
I'll take a look.
Comment 11 Simon Fraser (smfr) 2016-11-28 16:36:15 PST
I can't reproduce that failure locally.
Comment 12 Simon Fraser (smfr) 2016-11-28 22:47:07 PST
I filed bug 165133 to fix that.