Bug 16369

Summary: REGRESSION (r28525): regular expression tests failing due to bad firstByte optimization
Product: WebKit Reporter: Darin Adler <darin>
Component: JavaScriptCoreAssignee: Darin Adler <darin>
Status: RESOLVED FIXED    
Severity: Major    
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.4   
Attachments:
Description Flags
patch sam: review+

Description Darin Adler 2007-12-09 13:23:12 PST
Some of the PCRE regular expression tests started failing due to my breaking the firstByte optimization. I have a fix.
Comment 1 Darin Adler 2007-12-09 13:30:58 PST
Created attachment 17807 [details]
patch
Comment 2 Sam Weinig 2007-12-09 22:17:57 PST
Comment on attachment 17807 [details]
patch

This looks good. 

I am not sure if this and similar code near it needs to be quite as obfuscated as it is?
+    if ((cd.needOuterBracket ? bracketIsAnchored : branchIsAnchored)(codestart))

I think it would read clearer if it was just
+    if ((cd.needOuterBracket ? bracketIsAnchored(codestart) : branchIsAnchored(codestart))

Also, I know it is partially copied, but the ... in this comment doesn't seem necessary to me.
+.... except when the .* appears inside capturing parentheses, and there is a

r=me.
Comment 3 Darin Adler 2007-12-09 22:22:22 PST
Committed revision 28578.