Bug 16137

Summary: Web Inspector window on Leopard should have a unified toolbar and window title
Product: WebKit Reporter: Timothy Hatcher <timothy>
Component: Web Inspector (Deprecated)Assignee: Timothy Hatcher <timothy>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Attachments:
Description Flags
Picture of the change
none
Patch aroben: review+

Description Timothy Hatcher 2007-11-25 22:46:36 PST
The inspector window should have a unified title and toolbar. We can do this on Leopard.
Comment 1 Timothy Hatcher 2007-11-25 22:48:58 PST
Created attachment 17524 [details]
Picture of the change
Comment 2 Adam Roben (:aroben) 2007-11-25 22:51:52 PST
It would be nice to do this on Windows as well.
Comment 3 Adam Roben (:aroben) 2007-11-25 22:52:30 PST
(In reply to comment #2)
> It would be nice to do this on Windows as well.

...but we'd need transparent WebView support first.
Comment 4 Timothy Hatcher 2007-11-25 23:03:34 PST
Created attachment 17526 [details]
Patch

I will update libWebKitSystemInterfaceLeopard.a and libWebKitSystemInterfaceTiger.a when I land this.
Comment 5 Timothy Hatcher 2007-11-25 23:04:59 PST
I agree, it should be done on Windows too. Windows should use a metal window also.
Comment 6 Adam Roben (:aroben) 2007-11-25 23:13:51 PST
Comment on attachment 17526 [details]
Patch

+#if PLATFORM(MAC)
+#ifdef BUILDING_ON_TIGER
+    String platform = "mac-tiger";
+#else
+    String platform = "mac-leopard";
+#endif
+#elif PLATFORM(WIN_OS)
+    String platform = "windows";
+#elif PLATFORM(QT)
+    String platform = "qt";
+#elif PLATFORM(GTK)
+    String platform = "gtk";
+#elif PLATFORM(WX)
+    String platform = "wx";
+#else
+    String platform = "unknown";
+#endif

You should make these static const Strings.

+    JSStringRef platformString = JSStringCreateWithCharacters(platform.characters(), platform.length());

You should put this in a JSRetainPtr.

+        Add a new class to make window corners square for textured windows.

Typo: class -> function

+void WKNSWindowSquareBottomCorners(NSWindow *);

It would be nice to get a verb in there somewhere (using "square" as a verb isn't terribly clear). Maybe WKNSWindowMakeBottomCornersSquare?

r=me
Comment 7 Timothy Hatcher 2007-11-26 09:18:43 PST
Landed in r28039. http://trac.webkit.org/projects/webkit/changeset/28039