Bug 160372

Summary: We should not keep the JavaScript tests inside the Source/JavaScriptCore/ directory.
Product: WebKit Reporter: Keith Miller <keith_miller>
Component: Tools / TestsAssignee: Keith Miller <keith_miller>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, benjamin, bshafiei, fpizlo, ggaren, lforschler, mark.lam, mcatanzaro, mitz, msaboff, sbarati, ysuzuki
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Keith Miller 2016-07-29 19:25:20 PDT
Buckle your seatbelts, this is going to be a big patch.
Comment 1 Keith Miller 2016-08-01 00:28:38 PDT
It's happening! I hope this doesn't break everything... I hope no one commits anything in JavaScriptCore or Tools for the next ~2 hours.
Comment 2 Keith Miller 2016-08-01 00:31:48 PDT
Oh, well that was faster than I thought. I assumed that svn didn't do smart things with moving directories. That's a pleasant surprise.
Comment 3 mitz 2016-08-01 00:32:15 PDT
Is this a duplicate of bug 160180?
Comment 4 Keith Miller 2016-08-01 00:33:57 PDT
(In reply to comment #3)
> Is this a duplicate of bug 160180?

Looks like it. I'll mark the other one as a dup though.
Comment 5 Keith Miller 2016-08-01 00:34:22 PDT
Landed in https://trac.webkit.org/r203972.
Comment 6 Keith Miller 2016-08-01 00:38:15 PDT
*** Bug 160180 has been marked as a duplicate of this bug. ***
Comment 7 Michael Catanzaro 2016-08-11 13:09:27 PDT
Just noticed this.

It might make sense to move TestWebKitAPI up to the toplevel as well? It doesn't make much sense to me to have LayoutTests and JSTests and ManualTests and PerformanceTests at the toplevel, but bury API tests under Tools. Thoughts?