Bug 159194

Summary: [JSC] Fix build break since r202502
Product: WebKit Reporter: Joonghun Park <jh718.park>
Component: JavaScriptCoreAssignee: Joonghun Park <jh718.park>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, commit-queue, fpizlo, gyuyoung.kim, keith_miller, malvika.editsoftdigital, mark.lam, msaboff, sbarati
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Joonghun Park 2016-06-27 23:09:53 PDT
Add missing ASSERT_NOT_REACHED(); to TypeMap::at().
Comment 1 Joonghun Park 2016-06-27 23:27:29 PDT
Created attachment 282214 [details]
Patch
Comment 2 Alex Christensen 2016-06-27 23:48:35 PDT
Comment on attachment 282214 [details]
Patch

sure
Comment 3 Joonghun Park 2016-06-27 23:50:06 PDT
Comment on attachment 282214 [details]
Patch

Overall comments
Comment 4 WebKit Commit Bot 2016-06-28 00:10:20 PDT
Comment on attachment 282214 [details]
Patch

Clearing flags on attachment: 282214

Committed r202553: <http://trac.webkit.org/changeset/202553>
Comment 5 WebKit Commit Bot 2016-06-28 00:10:25 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Gyuyoung Kim 2016-06-28 00:26:02 PDT
hmm...this patch missed below compiler option. I already waited for passing ews in bug 159193 :(

#if COMPILER(GCC) && ASSERT_DISABLED
#pragma GCC diagnostic push
#pragma GCC diagnostic ignored "-Wreturn-type"
#endif // COMPILER(GCC) && ASSERT_DISABLED
Comment 7 Joonghun Park 2016-06-28 00:30:46 PDT
Reopening to attach new patch.
Comment 8 Joonghun Park 2016-06-28 00:30:52 PDT
Created attachment 282218 [details]
Patch
Comment 9 Joonghun Park 2016-06-28 00:34:25 PDT
(In reply to comment #6)
> hmm...this patch missed below compiler option. I already waited for passing
> ews in bug 159193 :(
> 
> #if COMPILER(GCC) && ASSERT_DISABLED
> #pragma GCC diagnostic push
> #pragma GCC diagnostic ignored "-Wreturn-type"
> #endif // COMPILER(GCC) && ASSERT_DISABLED

I see. Isn't it needed to add below also?
#if COMPILER(GCC) && ASSERT_DISABLED
#pragma GCC diagnostic pop
#endif // COMPILER(GCC) && ASSERT_DISABLED
Comment 10 Gyuyoung Kim 2016-06-28 00:37:37 PDT
Comment on attachment 282218 [details]
Patch

r=me based on Bug 159193 and Bug 152887.
Comment 11 Gyuyoung Kim 2016-06-28 00:38:19 PDT
*** Bug 159193 has been marked as a duplicate of this bug. ***
Comment 12 WebKit Commit Bot 2016-06-28 03:16:18 PDT
Comment on attachment 282218 [details]
Patch

Clearing flags on attachment: 282218

Committed r202555: <http://trac.webkit.org/changeset/202555>
Comment 13 WebKit Commit Bot 2016-06-28 03:16:24 PDT
All reviewed patches have been landed.  Closing bug.