Bug 159193

Summary: [JSC] Fix build warning since r202502
Product: WebKit Reporter: Gyuyoung Kim <gyuyoung.kim>
Component: JavaScriptCoreAssignee: Gyuyoung Kim <gyuyoung.kim>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, commit-queue, fpizlo, keith_miller, malvika.editsoftdigital, mark.lam, msaboff, sbarati, ysuzuki
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
none
Patch none

Description Gyuyoung Kim 2016-06-27 21:41:38 PDT
r202502 made a build warning because there is no default return value in TypeMap::at().

[107/4159] Building CXX object Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/b3/B3InsertionSet.cpp.o
In file included from ../../Source/JavaScriptCore/b3/B3InsertionSet.h:33:0,
                 from ../../Source/JavaScriptCore/b3/B3InsertionSet.cpp:27:
../../Source/JavaScriptCore/b3/B3TypeMap.h: In member function ‘T& JSC::B3::TypeMap<T>::at(JSC::B3::Type) [with T = JSC::B3::Value*]’:
../../Source/JavaScriptCore/b3/B3TypeMap.h:62:5: warning: control reaches end of non-void function [-Wreturn-type]
     }
     ^
Comment 1 Gyuyoung Kim 2016-06-27 21:42:43 PDT
Created attachment 282210 [details]
Patch
Comment 2 Yusuke Suzuki 2016-06-27 22:02:03 PDT
I think we should fix this like that https://bugs.webkit.org/show_bug.cgi?id=152887.
See the context. https://bugs.webkit.org/show_bug.cgi?id=150794#c7
Comment 3 Gyuyoung Kim 2016-06-27 22:23:56 PDT
Created attachment 282212 [details]
Patch
Comment 4 Gyuyoung Kim 2016-06-27 22:24:35 PDT
(In reply to comment #2)
> I think we should fix this like that
> https://bugs.webkit.org/show_bug.cgi?id=152887.
> See the context. https://bugs.webkit.org/show_bug.cgi?id=150794#c7

Looks like this fix is better than me. Fixed.
Comment 5 Yusuke Suzuki 2016-06-27 22:26:33 PDT
Comment on attachment 282212 [details]
Patch

r=me
Comment 6 Gyuyoung Kim 2016-06-28 00:33:10 PDT
Created attachment 282219 [details]
Patch
Comment 7 Gyuyoung Kim 2016-06-28 00:38:19 PDT

*** This bug has been marked as a duplicate of bug 159194 ***