Bug 158852

Summary: Opcode.h requires Bytecodes.h, but it is not found
Product: WebKit Reporter: Rafael Fontenelle <rafaelff>
Component: bmallocAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ggaren, Hironori.Fujii, ysuzuki
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Rafael Fontenelle 2016-06-16 15:17:25 PDT
Compilation fails when Opcode.h tries to include the header file 'Bytecodes.h', but there is no such file

See build and configure log: https://gist.github.com/josephgbr/b62ff3b2ba70d1ce523593a2d0335924
Comment 1 Yusuke Suzuki 2016-06-23 00:35:46 PDT
Reproduced on GTK port.
I think this is CMake build dependency issue. Bytecodes.h generation should be done before building any other cpps out of JSC.
Currently, it seems that WebCore binding code build starts before generating Bytecodes.h.

I think I saw such a problem in GYP in chromium...
Building the object files itself can be done without the shared library (libjavascriptcoregtk.so). Building WebCore and JavaScriptCore in parallel can be done if there are no such generated header dependencies.

So I guess that we need to explicitly say that these building depends on the Bytecodes.h header generation.
Comment 2 Yusuke Suzuki 2016-08-25 20:58:00 PDT
In https://trac.webkit.org/changeset/204994, I appended Bytecodes.h to JavaScriptCore_HEADERS in CMakeLists.txt.
Does this issue still remain?
Comment 3 Yusuke Suzuki 2016-08-31 21:03:50 PDT
Hm, the issue still remains.
Comment 4 Fujii Hironori 2016-09-01 07:01:40 PDT
Same?
  Bug 161477 – webkit-gtk 2.13.90 fails to build due to missing Bytecodes.h
Comment 5 Yusuke Suzuki 2016-09-01 09:24:36 PDT
(In reply to comment #4)
> Same?
>   Bug 161477 – webkit-gtk 2.13.90 fails to build due to missing Bytecodes.h

Nice!

*** This bug has been marked as a duplicate of bug 157261 ***