Bug 158617

Summary: REGRESSION (r200320): [GTK] resource-timing tests are broken
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED CONFIGURATION CHANGED    
Severity: Normal CC: achristensen, bugs-noreply, Hironori.Fujii, joepeck, lforschler, yoav
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 61138    

Description Carlos Alberto Lopez Perez 2016-06-10 09:30:14 PDT
Revision r200320 <http://trac.webkit.org/changeset/200320> changed the resource timing feature from a build-time to a run-time feature.

Since then, then resource timing tests have been broken on the GTK+ port.

I have tried to manually enable the feature on a test to check if it will work:

--- a/LayoutTests/http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_reparenting.html
+++ b/LayoutTests/http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_reparenting.html
@@ -31,6 +31,8 @@ function setup_iframe() {
     iframeBody.appendChild(move_to_child);
 }
 function onload_test() {
+    if (window.internals)
+        internals.setResourceTimingSupport(true);
     var context = new PerformanceContext(iframe.contentWindow.performance);
     var entries = context.getEntries();


And it started to work back.



Now I wonder:

 * Why this is only happening on the GTK+ port? The EFL port has all resource-timing tests skipped, but not the Mac one.
 * How are this tests working on the Mac port?
 * What should we do? Patch all tests to manually enable this feature?


$ find LayoutTests/ -type f -name TestExpectations|xargs grep resource-timing
LayoutTests/platform/efl/TestExpectations:webkit.org/b/61138 http/tests/w3c/webperf/submission/Intel/resource-timing [ Skip ]
LayoutTests/platform/efl/TestExpectations:webkit.org/b/61138 http/tests/w3c/webperf/submission/Google/resource-timing [ Skip ]
LayoutTests/platform/win/TestExpectations:webkit.org/b/61138 http/tests/w3c/webperf/submission/Intel/resource-timing [ Skip ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/127733 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_dynamic_insertion.html [ Failure Pass ]
LayoutTests/platform/gtk/TestExpectations:Bug(GTK) http/tests/w3c/webperf/submission/Intel/resource-timing [ Skip ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/103927 http/tests/w3c/webperf/submission/Intel/resource-timing/test_resource_timing_cross_origin_resource_request.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/103927 http/tests/w3c/webperf/submission/Intel/resource-timing/test_resource_timing_timing_allow_cross_origin_resource_request.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/103927 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_attribute_order.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/103927 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_frame_initiator_type.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/103927 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_initiator_types.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/103927 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_redirects.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/113772 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_iframe_self_navigation.html [ Failure ]
LayoutTests/platform/gtk/TestExpectations:webkit.org/b/113772 http/tests/w3c/webperf/submission/Google/resource-timing/html/test_resource_cached.html [ Failure ]
Comment 1 Yoav Weiss 2016-06-12 22:22:57 PDT
These tests are skipped on the mac port due to /LayoutTests/platform/mac/TestExpectations containing the line:
http/tests/w3c/webperf [ Skip ]

Is there a way to turn on a runtime flag by default for a port for testing purposes? I'm not aware of one.

Otherwise, rewriting the tests to turn on the runtime flag seems reasonable to me. I'll be happy to do that if others think the same.
Comment 2 Yoav Weiss 2016-06-12 23:44:42 PDT
Also seems like (at least some of) these tests are not passing with current implementation. They are passing elsewhere, so seems like the implementation needs some more work.

Is current ResourceTiming implementation something that is/was shipped with the GTK port?
Comment 3 Carlos Alberto Lopez Perez 2016-06-16 08:03:12 PDT
(In reply to comment #1)
> These tests are skipped on the mac port due to
> /LayoutTests/platform/mac/TestExpectations containing the line:
> http/tests/w3c/webperf [ Skip ]
> 

I see. I missed that

(In reply to comment #2)
> Also seems like (at least some of) these tests are not passing with current
> implementation. They are passing elsewhere, so seems like the implementation
> needs some more work.
> 
> Is current ResourceTiming implementation something that is/was shipped with
> the GTK port?

I'm not sure.
Comment 4 Joseph Pecoraro 2017-02-10 12:03:36 PST
These tests (any "webperf" tests) do not exist anymore. Lets close!