Bug 158397

Summary: [JSC] Rename thisValue => receiver and slotBase => holder
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: JavaScriptCoreAssignee: Yusuke Suzuki <ysuzuki>
Status: NEW ---    
Severity: Normal    
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Yusuke Suzuki 2016-06-05 07:26:59 PDT
Several code misuse thisValue and slotBase, and it sometimes incurs assertion failure.
Let's avoid `this` name. Instead, use |receiver| at least for property lookup.
This name "receiver" is spec-compilant name.