Bug 157263

Summary: New default-value-parsing-should-propagate-error.js fails on ARMv7 Thumb2
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ossy, sbarati, ysuzuki
Priority: P2    
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 108645, 157149    

Description Csaba Osztrogonác 2016-05-02 03:33:07 PDT
Source/JavaScriptCore/tests/stress/default-value-parsing-should-propagate-error.js introduced in
https://trac.webkit.org/changeset/200293 and fails on ARMv7 Thumb2 Linux (JSCOnly port):
https://build.webkit.org/builders/JSCOnly%20Linux%20ARMv7%20Thumb2%20Release/builds/437

It's strange that GTK ARMv7 Thumb2 and JSCOnly ARMv7 traditional isn't affected by this bug.

Running stress/default-value-parsing-should-propagate-error.js.default
stress/default-value-parsing-should-propagate-error.js.default: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.default: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.default: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.default: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.default
Running stress/default-value-parsing-should-propagate-error.js.always-trigger-copy-phase
stress/default-value-parsing-should-propagate-error.js.always-trigger-copy-phase: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.always-trigger-copy-phase: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.always-trigger-copy-phase: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.always-trigger-copy-phase: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.always-trigger-copy-phase
Running stress/default-value-parsing-should-propagate-error.js.no-llint
stress/default-value-parsing-should-propagate-error.js.no-llint: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.no-llint: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.no-llint: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.no-llint: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.no-llint
Running stress/default-value-parsing-should-propagate-error.js.no-cjit-validate-phases
stress/default-value-parsing-should-propagate-error.js.no-cjit-validate-phases: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.no-cjit-validate-phases: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.no-cjit-validate-phases: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.no-cjit-validate-phases: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.no-cjit-validate-phases
Running stress/default-value-parsing-should-propagate-error.js.dfg-eager
stress/default-value-parsing-should-propagate-error.js.dfg-eager: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.dfg-eager: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.dfg-eager: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.dfg-eager: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.dfg-eager
Running stress/default-value-parsing-should-propagate-error.js.dfg-eager-no-cjit-validate
stress/default-value-parsing-should-propagate-error.js.dfg-eager-no-cjit-validate: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.dfg-eager-no-cjit-validate: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.dfg-eager-no-cjit-validate: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.dfg-eager-no-cjit-validate: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.dfg-eager-no-cjit-validate
Running stress/default-value-parsing-should-propagate-error.js.dfg-maximal-flush-validate-no-cjit
stress/default-value-parsing-should-propagate-error.js.dfg-maximal-flush-validate-no-cjit: Exception: Error: Bad error: SyntaxError: new.target can't come after a prefix operator.
stress/default-value-parsing-should-propagate-error.js.dfg-maximal-flush-validate-no-cjit: testSyntaxError@default-value-parsing-should-propagate-error.js:12:24
stress/default-value-parsing-should-propagate-error.js.dfg-maximal-flush-validate-no-cjit: global code@default-value-parsing-should-propagate-error.js:16:16
stress/default-value-parsing-should-propagate-error.js.dfg-maximal-flush-validate-no-cjit: ERROR: Unexpected exit code: 3
FAIL: stress/default-value-parsing-should-propagate-error.js.dfg-maximal-flush-validate-no-cjit
Comment 1 Csaba Osztrogonác 2016-05-02 06:50:58 PDT
A clean build fixed it: 
https://build.webkit.org/builders/JSCOnly%20Linux%20ARMv7%20Thumb2%20Release/builds/453

new bug report to fix the build system: bug157266

*** This bug has been marked as a duplicate of bug 157266 ***