Bug 157261

Summary: Fix the Mac cmake clean build issue
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, commit-queue, darin, dino, Hironori.Fujii, ossy, rafaelff, sam, simon.fraser, youennf
Priority: P2    
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Csaba Osztrogonác 2016-05-02 02:41:01 PDT
clean build: https://build.webkit.org/builders/Apple%20El%20Capitan%20CMake%20Debug%20%28Build%29/builds/4733

error:
...
[  0%] Generating ../../DerivedSources/ForwardingHeaders/JavaScriptCore/Scripts/inline-and-minify-stylesheets-and-scripts.py
make[2]: *** No rule to make target `DerivedSources/ForwardingHeaders/JavaScriptCore/Scripts/inline-and-minify-stylesheets-and-scripts.py', needed by `DerivedSources/WebCore/InspectorOverlayPage.h'.  Stop.
make[2]: *** Waiting for unfinished jobs....
[  0%] Generating ../../DerivedSources/WebCore/CharsetData.cpp
[  0%] Generating ../../DerivedSources/ForwardingHeaders/JavaScriptCore/Scripts/jsmin.py
make[1]: *** [Source/WebCore/CMakeFiles/WebCoreDerivedSources.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
...
Comment 1 Csaba Osztrogonác 2016-08-25 05:52:56 PDT
this bug is still valid:
https://build.webkit.org/builders/Apple%20El%20Capitan%20CMake%20Debug%20%28Build%29/builds/7808
Comment 2 Fujii Hironori 2016-09-01 01:54:38 PDT
Created attachment 287610 [details]
Patch
Comment 3 Michael Catanzaro 2016-09-01 07:08:06 PDT
Comment on attachment 287610 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=287610&action=review

> Source/WebCore/CMakeLists.txt:3870
> +add_dependencies(WebCoreDerivedSources JavaScriptCore)

I wonder if we're missing this dependency anywhere else?
Comment 4 WebKit Commit Bot 2016-09-01 07:56:50 PDT
Comment on attachment 287610 [details]
Patch

Clearing flags on attachment: 287610

Committed r205291: <http://trac.webkit.org/changeset/205291>
Comment 5 WebKit Commit Bot 2016-09-01 07:56:54 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Yusuke Suzuki 2016-09-01 09:24:36 PDT
*** Bug 158852 has been marked as a duplicate of this bug. ***
Comment 7 Fujii Hironori 2016-09-01 20:01:17 PDT
Thank you for reviewing my patch.

(In reply to comment #3)
> I wonder if we're missing this dependency anywhere else?

This missing dependency problem can be reproduced with like following steps:

1) rm -rf WebKitBuild/Debug
2) ./Tools/Scripts/build-webkit --gtk --64-bit --debug
3) Ctrl-C to abort build after CMake finished.
4) ninja-build -C WebKitBuild/Debug WebCoreDerivedSources
5) Build fails