Bug 154918

Summary: REGRESSION(r197409): [GTK] Web process always crashes on WebPage construction after r197409
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKit2Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, darin, kling, thorton
Priority: P2 Keywords: Gtk, Regression
Version: WebKit Local Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch zan: review+

Description Carlos Garcia Campos 2016-03-02 09:15:36 PST
We have an incorrect check in DrawingAreaImpl constructor that has never actually worked because it uses the page settings before they were initialized. But that has been fixed in r197409 and now we are always forcing accelerated compositing mode incorrectly, because m_alwaysUseCompositing is set in the constructor and never changed again.
Comment 1 Carlos Garcia Campos 2016-03-02 09:21:31 PST
Created attachment 272658 [details]
Patch

Please, review this, *all* the tests in our bots are currently broken
Comment 2 Carlos Garcia Campos 2016-03-02 09:24:42 PST
Created attachment 272659 [details]
Patch

Sorry, I submitted the wrong patch by mistake.
Comment 3 Carlos Garcia Campos 2016-03-02 09:59:32 PST
Committed r197452: <http://trac.webkit.org/changeset/197452>