Bug 154853

Summary: New stress/proxy-call.js test fails on ARM Linux
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Critical CC: mark.lam, ossy, sbarati
Priority: P1    
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=151701
Bug Depends on:    
Bug Blocks: 108645, 154425    

Description Csaba Osztrogonác 2016-03-01 04:06:01 PST
stress/proxy-call.js introduced in http://trac.webkit.org/changeset/196836 ,
but fails on ARM Linux 32 bit with ARM instruction set, but passes with Thumb2.

Running stress/proxy-call.js.default
stress/proxy-call.js.default: Exception: Error: Bad assertion
stress/proxy-call.js.default: assert@proxy-call.js:3:24
stress/proxy-call.js.default: foo@proxy-call.js:8:15
stress/proxy-call.js.default: apply@proxy-call.js:17:35
stress/proxy-call.js.default: [native code]
stress/proxy-call.js.default: global code@proxy-call.js:22:21
stress/proxy-call.js.default: ERROR: Unexpected exit code: 3
FAIL: stress/proxy-call.js.default

It fails in all configuration:
	stress/proxy-call.js.always-trigger-copy-phase
	stress/proxy-call.js.default
	stress/proxy-call.js.dfg-eager
	stress/proxy-call.js.dfg-eager-no-cjit-validate
	stress/proxy-call.js.dfg-maximal-flush-validate-no-cjit
	stress/proxy-call.js.no-cjit-validate-phases
	stress/proxy-call.js.no-llint
Comment 1 Csaba Osztrogonác 2016-03-01 04:52:22 PST
similar bug: bug154856
Comment 2 Csaba Osztrogonác 2017-06-20 02:07:55 PDT

*** This bug has been marked as a duplicate of bug 172972 ***