Bug 153136

Summary: Add kdebug_trace signposts for a few WebCore operations
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: New BugsAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, cdumez, cmarcelo, commit-queue, esprehn+autocc, kangil.han, rniwa, sabouhallawa, simon.fraser, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 153351    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch
sam: review+
Patch none

Description Simon Fraser (smfr) 2016-01-15 10:41:15 PST
Add kdebug_trace signposts for a few WebCore operations
Comment 1 Simon Fraser (smfr) 2016-01-15 10:44:36 PST
Created attachment 269066 [details]
Patch
Comment 2 Simon Fraser (smfr) 2016-01-15 10:45:54 PST
Created attachment 269067 [details]
Patch
Comment 3 Simon Fraser (smfr) 2016-01-15 10:46:27 PST
rdar://problem/24208487
Comment 4 Chris Dumez 2016-01-15 10:48:54 PST
Comment on attachment 269067 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=269067&action=review

> Source/WTF/wtf/KDebugTracing.h:64
> +        : m_exitCode(exitCode)

This won't build on non-DARWIN.
Comment 5 Simon Fraser (smfr) 2016-01-15 11:00:06 PST
Created attachment 269070 [details]
Patch
Comment 6 Chris Dumez 2016-01-15 11:02:22 PST
Comment on attachment 269070 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=269070&action=review

> Source/WTF/wtf/KDebugTracing.h:68
> +#if defined(HAVE_KDEBUG_H)

Don't we usually use HAVE() macro for these?

e.g. #if HAVE(KDEBUG_H)
Comment 7 Simon Fraser (smfr) 2016-01-15 11:16:34 PST
Created attachment 269071 [details]
Patch
Comment 8 Sam Weinig 2016-01-15 11:35:40 PST
Comment on attachment 269071 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=269071&action=review

> Source/WTF/wtf/KDebugTracing.h:27
> +#define KDebugTracing_h

Since this is defining generic tracing utilities, perhaps this file should be called something else.  Maybe just Tracing.h?

> Source/WTF/wtf/KDebugTracing.h:64
> +class TraceEntryExit {

Maybe TraceScope?
Comment 9 Simon Fraser (smfr) 2016-01-15 11:58:05 PST
Created attachment 269076 [details]
Patch
Comment 10 Simon Fraser (smfr) 2016-01-15 12:58:14 PST
https://trac.webkit.org/r195142