Bug 150456

Summary: Add more Air optimizations
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: ossy
Priority: P2    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on: 150457, 150478, 150746, 150960, 152952, 153197, 153535    
Bug Blocks: 150279    

Description Filip Pizlo 2015-10-22 11:11:30 PDT
Here's what we need:

- Register allocation.
- Dead code elimination. We should run this before and after register allocation.
- CFG simplification. At a minium, we should be able to remove blocks that just have a jump.
Comment 1 Filip Pizlo 2016-02-16 18:28:39 PST

*** This bug has been marked as a duplicate of bug 154319 ***
Comment 2 Filip Pizlo 2016-02-16 18:28:58 PST
I didn't mean to dup it.
Comment 3 Filip Pizlo 2016-02-16 18:29:20 PST
We did enough of this, future improvements will be tracked by https://bugs.webkit.org/show_bug.cgi?id=154319