Bug 149550

Summary: Add WebKitSystemInterface for iOS 9.0
Product: WebKit Reporter: Daniel Bates <dbates>
Component: Tools / TestsAssignee: Daniel Bates <dbates>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, commit-queue, ddkilzer, dean_johnson, lforschler
Priority: P2    
Version: WebKit Local Build   
Hardware: iPhone / iPad   
OS: iOS 9.0   
Attachments:
Description Flags
Patch ap: review+

Description Daniel Bates 2015-09-24 22:50:19 PDT
We should add WKSI libraries for iOS 9.0.
Comment 1 Daniel Bates 2015-09-24 22:51:51 PDT
Created attachment 261914 [details]
Patch
Comment 2 WebKit Commit Bot 2015-09-24 22:54:28 PDT
Attachment 261914 [details] did not pass style-queue:


ERROR: WebKitLibraries/WebKitSystemInterface.h:57:  The parameter name "request" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:73:  The parameter name "cgContext" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:96:  The parameter name "font" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:96:  The parameter name "options" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:104:  The parameter name "image" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:104:  The parameter name "transform" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:107:  The parameter name "context" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:108:  The parameter name "context" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:138:  The parameter name "port" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:147:  The parameter name "layer" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:147:  The parameter name "context" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:160:  The parameter name "request" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:165:  The parameter name "response" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:183:  The parameter name "type" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:184:  The parameter name "sandboxExtension" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:186:  The parameter name "sandboxExtension" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:187:  The parameter name "sandboxExtension" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:189:  The parameter name "sandboxExtension" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:194:  The parameter name "path" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:194:  The parameter name "rect" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:423:  The parameter name "subsystem" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:441:  The parameter name "eventRef" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:442:  The parameter name "window" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: WebKitLibraries/WebKitSystemInterface.h:443:  The parameter name "windowRef" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 24 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Alexey Proskuryakov 2015-09-24 23:12:56 PDT
Comment on attachment 261914 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261914&action=review

rs=me

> WebKitLibraries/WebKitSystemInterface.h:57
> -void WKSetNSURLRequestShouldContentSniff(NSMutableURLRequest *, BOOL shouldContentSniff);
> +void WKSetNSURLRequestShouldContentSniff(NSMutableURLRequest *request, BOOL shouldContentSniff);

What happened with all the argument names? Adding argument names is the only thing that this patch changes in WebKitSystemInterface.h.
Comment 4 Daniel Bates 2015-09-24 23:53:42 PDT
(In reply to comment #3)
> > WebKitLibraries/WebKitSystemInterface.h:57
> > -void WKSetNSURLRequestShouldContentSniff(NSMutableURLRequest *, BOOL shouldContentSniff);
> > +void WKSetNSURLRequestShouldContentSniff(NSMutableURLRequest *request, BOOL shouldContentSniff);
> 
> What happened with all the argument names? Adding argument names is the only
> thing that this patch changes in WebKitSystemInterface.h.

The argument names were removed in the patch for bug #145009. I suspect to the make the style checker happy after <https://bugs.webkit.org/show_bug.cgi?id=145009#c11>. Maybe we should make WebKitSystemInterface.h conform to the WebKit Code Style Guidelines. Regardless, I suggest we do this in a separate patch as we will need to coordinate such a change internally.
Comment 5 Daniel Bates 2015-09-24 23:58:48 PDT
Committed r190237: <http://trac.webkit.org/changeset/190237>