Bug 149542

Summary: Remove the use of "Immediate" in JIT function names.
Product: WebKit Reporter: Mark Lam <mark.lam>
Component: JavaScriptCoreAssignee: Mark Lam <mark.lam>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P2    
Version: WebKit Local Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
the fix.
none
fix 2: fixed style issues. none

Description Mark Lam 2015-09-24 14:54:54 PDT
We will rename the following:
    isOperandConstantImmediateDouble => isOperandConstantDouble
    getOperandConstantImmediateInt => getOperandConstantInt
    getConstantOperandImmediateInt => getOperandConstantInt

    emitJumpIfImmediateInteger => emitJumpIfInt
    emitJumpIfNotImmediateInteger => emitJumpIfNotInt
    emitJumpIfNotImmediateIntegers => emitJumpIfNotInt
    emitPatchableJumpIfNotImmediateInteger => emitPatchableJumpIfNotInt
    emitJumpSlowCaseIfNotImmediateInteger => emitJumpSlowCaseIfNotInt
    emitJumpSlowCaseIfNotImmediateNumber => emitJumpSlowCaseIfNotNumber
    emitJumpSlowCaseIfNotImmediateIntegers => emitJumpSlowCaseIfNotInt
    emitFastArithReTagImmediate => emitTagInt
    emitTagAsBoolImmediate => emitTagBool

    isOperandConstantImmediateInt => isOperandConstantInt
    isOperandConstantImmediateChar => isOperandConstantChar

    emitJumpIfImmediateNumber => emitJumpIfNumber
    emitJumpIfNotImmediateNumber => emitJumpIfNotNumber
    emitFastArithImmToInt - Deleted because this is an empty function.
    emitFastArithIntToImmNoCheck => emitTagInt
    emitPutImmediateToCallFrameHeader => emitPutToCallFrameHeader
Comment 1 Mark Lam 2015-09-24 15:02:49 PDT
One more:
    emitPutImmediateToCallFrameHeader => emitPutToCallFrameHeader
Comment 2 Mark Lam 2015-09-24 15:48:51 PDT
Created attachment 261899 [details]
the fix.
Comment 3 WebKit Commit Bot 2015-09-24 15:51:08 PDT
Attachment 261899 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/jit/JIT.h:466:  The parameter name "reg" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/JSInterfaceJIT.h:68:  The parameter name "reg" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/jit/JSInterfaceJIT.h:69:  The parameter name "reg" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 3 in 14 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Mark Lam 2015-09-24 15:55:01 PDT
Created attachment 261900 [details]
fix 2: fixed style issues.
Comment 5 Geoffrey Garen 2015-09-24 16:32:28 PDT
Comment on attachment 261900 [details]
fix 2: fixed style issues.

r=me
Comment 6 WebKit Commit Bot 2015-09-24 17:17:37 PDT
Comment on attachment 261900 [details]
fix 2: fixed style issues.

Clearing flags on attachment: 261900

Committed r190230: <http://trac.webkit.org/changeset/190230>
Comment 7 WebKit Commit Bot 2015-09-24 17:17:41 PDT
All reviewed patches have been landed.  Closing bug.