Bug 149129

Summary: [ES6] Add more fine-grained APIs and additional hooks to control module loader from WebCore
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: New BugsAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED FIXED    
Severity: Normal CC: saam
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 147340, 148897    
Attachments:
Description Flags
Patch
none
Patch saam: review+

Description Yusuke Suzuki 2015-09-14 14:34:21 PDT
[ES6] Add more fine-grained APIs and additional hooks to control module loader from WebCore
Comment 1 Yusuke Suzuki 2015-09-14 15:11:41 PDT
Created attachment 261135 [details]
Patch
Comment 2 Yusuke Suzuki 2015-09-16 21:57:56 PDT
Created attachment 261366 [details]
Patch

More clean up
Comment 3 Saam Barati 2015-09-17 13:19:10 PDT
Comment on attachment 261366 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261366&action=review

r=me with comment

> Source/JavaScriptCore/builtins/ModuleLoaderObject.js:541
> +function prepareModuleGraph(moduleName, referrer)

I think we need a better name for this, maybe: "loadAndExecuteModule" or "loadAndEvaluateModule"?
Or something that indicates execution better than "prepare". I don't think "graph" is needed in the name.
Comment 4 Yusuke Suzuki 2015-09-17 13:44:47 PDT
Comment on attachment 261366 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261366&action=review

Thank you for your review!

>> Source/JavaScriptCore/builtins/ModuleLoaderObject.js:541
>> +function prepareModuleGraph(moduleName, referrer)
> 
> I think we need a better name for this, maybe: "loadAndExecuteModule" or "loadAndEvaluateModule"?
> Or something that indicates execution better than "prepare". I don't think "graph" is needed in the name.

After discussing with you on IRC, I'll rename APIs.
prepareModuleGraph => loadModule, loadModuleGraph => loadAndEvaluateModule, and linkAndEvaluateModuleGraph => linkAndEvaluateModule
Comment 5 Yusuke Suzuki 2015-09-17 15:26:32 PDT
Committed r189941: <http://trac.webkit.org/changeset/189941>