Bug 148433

Summary: [GStreamer] "method" property for the webkitwebsrc element
Product: WebKit Reporter: Philippe Normand <pnormand>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Severity: Normal CC: cgarcia, mrobinson, pnormand
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
patch cgarcia: review+

Description Philippe Normand 2015-08-25 08:52:43 PDT
The GStreamer uridownloader element makes use of this property in some cases for DASH. See also https://bugzilla.gnome.org/show_bug.cgi?id=752413

So we should also add this property in webkitwebsrc, the patch is trivial.
Comment 1 Philippe Normand 2015-08-25 09:00:39 PDT
Created attachment 259847 [details]
Comment 2 Carlos Garcia Campos 2015-08-26 00:27:05 PDT
Comment on attachment 259847 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=259847&action=review

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:116
> +    GUniquePtr<gchar> method;

method is quite confusing name, we can't change the property name, of course, but at least the variable could be httpMethod or something like that, I didn't know what this was about until I read the full patch.

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:269
> +            0, static_cast<GParamFlags>(G_PARAM_READWRITE | G_PARAM_STATIC_STRINGS)));

Comment 3 Philippe Normand 2015-08-26 02:51:44 PDT
Committed r188961: <http://trac.webkit.org/changeset/188961>