Bug 147747

Summary: jsc-tailcall: Stop saving and restoring all callee saves on vmEntry / exit for platforms with per function callee saves handling
Product: WebKit Reporter: Michael Saboff <msaboff>
Component: JavaScriptCoreAssignee: Michael Saboff <msaboff>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: basile_clement
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 147639, 147759    
Bug Blocks: 146845    
Attachments:
Description Flags
Patch none

Description Michael Saboff 2015-08-06 14:35:07 PDT
We don't need to save and restore all possible callee save registers at VM entry time for the platforms that properly handle callee save registers on function entry and exit.  Currently this is just the 64 bit platforms.
Comment 1 Michael Saboff 2015-08-06 14:40:18 PDT
Created attachment 258399 [details]
Patch
Comment 2 Basile Clement 2015-08-06 15:24:52 PDT
Comment on attachment 258399 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=258399&action=review

LGTM

> Source/JavaScriptCore/llint/LowLevelInterpreter.asm:400
> +if C_LOOP or ARM64 or X86_64 or X86_64_WIN

I'd add a comment stating that this is handled correctly by the engine on 64 bits platforms.
Comment 3 Michael Saboff 2015-08-06 15:45:31 PDT
Committed r188072: <http://trac.webkit.org/changeset/188072>
Comment 4 Michael Saboff 2015-08-17 19:31:19 PDT
Committed r188568: <http://trac.webkit.org/changeset/188568>
Comment 5 Michael Saboff 2015-08-17 19:32:47 PDT
Relanded patch after fixes landed in change sets r188555 & r188556.
Comment 6 Basile Clement 2015-08-31 18:10:42 PDT

*** This bug has been marked as a duplicate of bug 148666 ***
Comment 7 Csaba Osztrogon√°c 2015-09-14 10:58:56 PDT
Comment on attachment 258399 [details]
Patch

Cleared review? from attachment 258399 [details] so that this bug does not appear in http://webkit.org/pending-review.  If you would like this patch reviewed, please attach it to a new bug (or re-open this bug before marking it for review again).