Bug 146845 - jsc-tailcall: LLint, Baseline JIT and DFG should respect the platform's callee-save register conventions
Summary: jsc-tailcall: LLint, Baseline JIT and DFG should respect the platform's calle...
Status: RESOLVED DUPLICATE of bug 148666
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Enhancement
Assignee: Nobody
URL:
Keywords:
Depends on: 146849 146946 147639 147747
Blocks: 146854
  Show dependency treegraph
 
Reported: 2015-07-10 12:20 PDT by Basile Clement
Modified: 2015-08-31 18:07 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Basile Clement 2015-07-10 12:20:18 PDT
This will allow to remove the register preservation thunk when calling non-FTL code from FTL code, since we will already be correctly saving the callee-save registers we use.
Comment 1 Basile Clement 2015-08-31 18:07:55 PDT

*** This bug has been marked as a duplicate of bug 148666 ***