Bug 147682

Summary: [GTK] Crash closing a page when a context menu is open
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: svillar, zan
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch svillar: review+

Description Carlos Garcia Campos 2015-08-05 05:40:51 PDT
This was fixed in mac port in r180094, but I don't know which previous revision introduced the regression. It can be reproduced with /webkit2/WebKitWebView/populate-menu but we didn't notice it because the TestContextMenu test is still skipped in the bots :-/ This also affects to 2.8 branch.
Comment 1 Carlos Garcia Campos 2015-08-05 05:55:56 PDT
Created attachment 258274 [details]
Patch
Comment 2 Sergio Villar Senin 2015-08-06 00:27:49 PDT
Comment on attachment 258274 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=258274&action=review

> Source/WebKit2/UIProcess/gtk/WebContextMenuProxyGtk.cpp:196
> +    for (auto iter = m_signalHandlers.begin(); iter != m_signalHandlers.end(); ++iter)

for (auto handler : m_signalHandlers)
Comment 3 Carlos Garcia Campos 2015-08-06 01:14:41 PDT
Committed r188031: <http://trac.webkit.org/changeset/188031>