Bug 146742

Summary: Media Session: indicate to clients whether a media session has active media elements
Product: WebKit Reporter: Matt Rajca <mrajca>
Component: MediaAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: conrad_shultz, eric.carlson, jer.noble, mrajca, thorton, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 145411    
Attachments:
Description Flags
Patch
none
Patch thorton: review+

Description Matt Rajca 2015-07-08 15:41:05 PDT
Indicate to clients whether there are active media elements in a media session.
Comment 1 Radar WebKit Bug Importer 2015-07-08 15:42:11 PDT
<rdar://problem/21734470>
Comment 2 Matt Rajca 2015-07-08 15:46:05 PDT
Created attachment 256412 [details]
Patch
Comment 3 Tim Horton 2015-07-08 16:09:30 PDT
Comment on attachment 256412 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=256412&action=review

> Source/WebKit2/UIProcess/API/C/WKPage.cpp:2156
> +bool WKPageHasActiveMediaElements(WKPageRef page)

Seems pretty bizarre that something called this would return false if you have a <video> on the page (but have MEDIA_SESSION off)...
Comment 4 Matt Rajca 2015-07-08 16:13:28 PDT
(In reply to comment #3)
> Comment on attachment 256412 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=256412&action=review
> 
> > Source/WebKit2/UIProcess/API/C/WKPage.cpp:2156
> > +bool WKPageHasActiveMediaElements(WKPageRef page)
> 
> Seems pretty bizarre that something called this would return false if you
> have a <video> on the page (but have MEDIA_SESSION off)...

I'll rename it to WKPageHasMediaSessionWithActiveMediaElements.
Comment 5 Matt Rajca 2015-07-08 16:34:55 PDT
Created attachment 256421 [details]
Patch
Comment 6 Matt Rajca 2015-07-08 16:47:31 PDT
Committed r186538: <http://trac.webkit.org/changeset/186538>