Bug 146204

Summary: [Streams API] Implement ReadableStream js source "'cancel" callback
Product: WebKit Reporter: youenn fablet <youennf>
Component: WebCore Misc.Assignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, calvaris, commit-queue, darin
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 138967    
Attachments:
Description Flags
Patch
none
Patch for landing none

youenn fablet
Reported 2015-06-22 06:05:59 PDT
Attachments
Patch (13.86 KB, patch)
2015-06-22 06:18 PDT, youenn fablet
no flags
Patch for landing (15.17 KB, patch)
2015-06-23 03:33 PDT, youenn fablet
no flags
youenn fablet
Comment 1 2015-06-22 06:18:55 PDT
Darin Adler
Comment 2 2015-06-22 10:01:00 PDT
Comment on attachment 255346 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=255346&action=review > Source/WebCore/bindings/js/ReadableJSStream.cpp:164 > +static JSFunction* createCancelResultFulfilledFunction(ExecState& exec, ReadableJSStream& jsStream) I would name this argument “stream”, not “jsStream”. I don’t think the prefix does anything significant to help programmers understand the code. > Source/WebCore/bindings/js/ReadableJSStream.cpp:166 > + RefPtr<ReadableJSStream> readableStream = &jsStream; I know we need a different name for this local, but it seems that adding the word “readable” doesn’t do much good to explain why a local variable is needed. I think protectedStream would be a better name. > Source/WebCore/bindings/js/ReadableJSStream.cpp:185 > + ExecState& exec= *globalObject()->globalExec(); Missing space before "=". I suggest in new code we use “state” for our ExecState& and we can keep using “exec” for ExecState*.
youenn fablet
Comment 3 2015-06-23 03:33:13 PDT
Created attachment 255403 [details] Patch for landing
WebKit Commit Bot
Comment 4 2015-06-23 04:30:20 PDT
Comment on attachment 255403 [details] Patch for landing Clearing flags on attachment: 255403 Committed r185872: <http://trac.webkit.org/changeset/185872>
WebKit Commit Bot
Comment 5 2015-06-23 04:30:24 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.